F - Subsequence

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

Many test cases will be given. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.

Sample Input

10 15
5 1 3 5 10 7 4 9 2 8 5 11
12345

Sample Output

2 3

/* UVALive2678 UVA1121 Subsequence */
 
#include <iostream>
#include <algorithm>
 
using namespace std;
 
const int N = 100000;
int prefixsum[N+1];
 
int main()
{
    int n, s, val, ans;
 
    while(cin >> n >> s) {
        // 输入数据,计算前缀和
        prefixsum[0] = 0;
        for(int i=1; i<=n; i++) {
            cin >> val;
 
            prefixsum[i] = prefixsum[i - 1] + val;
        }
 
        if(prefixsum[n] < s)
            ans = 0;
        else {
            ans = n;
            for(int i=0; prefixsum[i] + s < prefixsum[n]; i++) {
                int pos = lower_bound(prefixsum + i, prefixsum + n, prefixsum[i] + s) - prefixsum;
                ans = min(ans, pos - i);
            }
        }
 
        cout << ans << endl;
    }
 
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

郭晋龙

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值