暑假每日算法学习打卡(七)----Subsequence(尺取法)【牛客】

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

Many test cases will be given. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.

Sample Input

10 15

5 1 3 5 10 7 4 9 2 8

5 11

1 2 3 4 5

Sample Output

2

3

题目翻译

N个正整数(10<N<100000)的序列,每个正整数小于或等于10000,以及
给出了一个正整数S(S<100 000 000)。编写一个程序以查找
序列中连续元素的子序列,其总和大于或等于S。
输入
将给出许多测试用例。对于每个测试用例,程序必须读取数字N和S,
由间隔隔开,从第一行开始。序列号在第二行中给出
由间隔分隔的测试用例。输入将在文件结束时完成。
输出
对于每种情况,程序都必须在输出文件的单独一行上打印结果。

思路:尺取法,相当于用s去序列里取符合要求的,记录它长度,不断更新它的最小长度;

AC代码: 

#include <iostream>
#include<string.h>

using namespace std;

int t,n,s;
int a[100010];
int main()
{
    while(cin>>n>>s)
    {
        memset(a,0,sizeof(a));
        for(int i=1;i<=n;i++)
        {
            cin>>a[i];
        }
        int len=n+1,r=0,sum=0;
        for(int l=1;l<=n;l++)
        {
            while(sum<s&&r<=n)
            {
                r++;
              sum+=a[r];
            }
           if(sum>=s)
           {
              len=min(len,r-l+1);
           }
           sum-=a[l];
        }
        if(len!=n+1)
        cout << len << endl;
        else cout<<"0"<<endl;
    }
    return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值