Travel in time HDU - 4571

  Bob gets tired of playing games, leaves Alice, and travels to Changsha alone. Yuelu Mountain, Orange Island, Window of the World, the Provincial Museum etc...are scenic spots Bob wants to visit. However, his time is very limited, he can’t visit them all. 
  Assuming that there are N scenic spots in Changsha, Bob defines a satisfaction value Si to each spot. If he visits this spot, his total satisfaction value will plus Si. Bob hopes that within the limited time T, he can start at spot S, visit some spots selectively, and finally stop at spot E, so that the total satisfaction value can be as large as possible. It's obvious that visiting the spot will also cost some time, suppose that it takes Ci units of time to visit spot i ( 0 <= i < N ). 
  Always remember, Bob can choose to pass by a spot without visiting it (including S and E), maybe he just want to walk shorter distance for saving time. 
  Bob also has a special need which is that he will only visit the spot whose satisfaction value is strictly larger than that of which he visited last time. For example, if he has visited a spot whose satisfaction value is 50, he would only visit spot whose satisfaction value is 51 or more then. The paths between the spots are bi-directional, of course.

Input

  The first line is an integer W, which is the number of testing cases, and the W sets of data are following. 
  The first line of each test data contains five integers: N M T S E. N represents the number of spots, 1 < N < 100; M represents the number of paths, 0 < M < 1000; T represents the time limitation, 0 < T <= 300; S means the spot Bob starts from. E indicates the end spot. (0 <= S, E < N) 
  The second line of the test data contains N integers Ci ( 0 <= Ci <= T ), which means the cost of time if Bob visits the spot i. 
  The third line also has N integers, which means the satisfaction value Si that can be obtained by visiting the spot i ( 0 <= Si < 100 ). 
  The next M lines, each line contains three integers u v L, means there is a bi-directional path between spot u and v and it takes L units of time to walk from u to v or from v to u. (0 <= u, v < N, 0 <= L <= T)

Output

  Output case number in the first line (formatted as the sample output). 
  The second line contains an integer, which is the greatest satisfaction value. 
If Bob can’t reach spot E in T units of time, you should output just a “0” (without quotation marks).

Sample Input

1
4 4 22 0 3
1 1 1 1
5 7 9 12
0 1 10
1 3 10
0 2 10
2 3 10

Sample Output

Case #1:
21
#include<iostream>
#include<cstdio>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int N=105;
const int INF = 0x3f3f3f3f;
int n,m,t,s,e;
int ti[N],val[N],g[N][N];
int dp[N][N][N*3];
void Floyd(){
    for(int i=0;i<n;i++){
        g[i][i]=0;
    }
    for(int k=0;k<n;k++){
        for(int i=0;i<n;i++){
            for(int j=0;j<n;j++){
                g[i][j]=min(g[i][j],g[i][k]+g[k][j]);
            }
        }
    }
}
void init(){
    memset(dp,-1,sizeof(dp));
    memset(g,INF,sizeof(g));
    cin>>n>>m>>t>>s>>e;
    for(int i=0;i<n;i++) cin>>ti[i];
    for(int i=0;i<n;i++) cin>>val[i];
    int a,b,v;
    for(int i=0;i<m;i++) {
        cin>>a>>b>>v;
        g[a][b]=g[b][a]=min(g[a][b],v);
    }
    Floyd();
}
int dfs(int u,int value,int t){
    if(g[u][e]>t) return -INF;
    if(dp[u][value][t]!=-1) return dp[u][value][t];
    int &ans=dp[u][value][t];
    ans=0;
    for(int i=0;i<n;i++){
        if(value>=val[i]) continue;
        ans=max(ans,dfs(i,val[i],t-ti[i]-g[u][i])+val[i]);
    }
    return ans;
    
}
int main(){
    int cas;
    cin>>cas;
    for(int i=1;i<=cas;i++){
        init();
        printf("Case #%d:\n%d\n", i, dfs (s, 0, t));
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

郭晋龙

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值