34-统计子矩阵(蓝桥杯)

问题描述

输入格式

第一行包含三个整数 N,MK.

之后 N 行每行包含 M 个整数, 代表矩阵 A.

输出格式

一个整数代表答案。

样例输入

样例输出

样例说明

运行限制

  • 最大运行时间:1s

  • 最大运行内存: 256M

源码:

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;



public class 统计子矩阵 {

    static int N=510;
    static int[][] a=new int[N][N];
    static int[][] s=new int[N][N];
    static int n,m,k;
    static BufferedReader br=new BufferedReader(new InputStreamReader(System.in));
    public static void main(String[] args) throws IOException {
        String[] ts=br.readLine().split(" ");
        n=Integer.parseInt(ts[0]);
        m=Integer.parseInt(ts[1]);
        k=Integer.parseInt(ts[2]);
        for (int i = 1; i <= n; i++) {
            ts=br.readLine().split(" ");
            for (int j = 1; j <= m; j++) {
                a[i][j]=Integer.parseInt(ts[j-1]);
                s[i][j]=s[i-1][j]+s[i][j-1]-s[i-1][j-1]+a[i][j];
            }
        }
        //res long  r和l都是int
        long res=0;
        //枚举上下的边
        //使用双指针
        for (int x1 = 1; x1 <= n; x1++) {
            for (int x2 = x1; x2 <= n; x2++) {
                //枚举l和r
                int l=1;
                int r=1;
                while(r<=m) {
                    while(l<=r && !check(x1,l,x2,r)) l++;
                    res+=(long)r-l+1;
                    r++;
                }
            }
        }
        System.out.println(res);
    }
    private static boolean check(int x1, int y1, int x2, int y2) {
        return s[x2][y2]-s[x1-1][y2]-s[x2][y1-1]+s[x1-1][y1-1]<=k;
    }

}

这里res+=(long)r-l+1的意思是 矩阵的右边界为r的情况下符合要求的矩阵个数

l最多可以移动r-l次,加上本来的l自己的位置

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

月亮被咬碎成星星

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值