我的Python旅程——函数

文章目录


问题描述

编写函数 number,接收一个字符串,分别统计大写字母、小写字母、数字、其他字符的个数,并以元组的形式返回结果。

并编写主程序调用该函数。 主调程序如下:

s = input()
print(demo(s))

样例输入:Hello World!

样例输出:(2, 8, 0, 2)

解答

def demo(n):
    NUM=num=digit=other=0
    for i in n:
        if 'A'<=i<='Z':
            NUM=NUM+1
        elif 'a'<=i<='z':
            num=num+1
        elif '0'<=i<='9':
            digit=digit+1
        else:
            other=other+1
    return(NUM,num,digit,other)

s = input()
print(demo(s))
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值