Java算法_Map——HDU 2648:Shopping

HDU 2648:Shopping

http://acm.hdu.edu.cn/showproblem.php?pid=2648

Problem Description

Every girl likes shopping,so does dandelion.Now she finds the shop is increasing the price every day because the Spring Festival is coming .She is fond of a shop which is called “memory”. Now she wants to know the rank of this shop’s price after the change of everyday.

每个女孩都喜欢购物,蒲公英也是。现在她发现商店每天都在涨价,因为春节就要到了。她很喜欢一家叫“记忆”的商店。现在她想知道这家店的价格在每天变化后的排名。

Input

One line contians a number n ( n<=10000),stands for the number of shops.
Then n lines ,each line contains a string (the length is short than 31 and only contains lowercase letters and capital letters.)stands for the name of the shop.
Then a line contians a number m (1<=m<=50),stands for the days .
Then m parts , every parts contians n lines , each line contians a number s and a string p ,stands for this day ,the shop p 's price has increased s.

一行中有一个数字n (n<=10000),表示商店的数量。

然后n行,每行包含一个字符串(长度小于31且只包含小写字母和大写字母),代表商店的名称。

然后一行中有一个数字m (1<=m<=50),表示天数。

那么m个部分,每个部分包含n行,每一行包含一个数字s和一个字符串p,代表这一天,商店p的价格上涨了s。

Output

Contains m lines ,In the ith line print a number of the shop “memory” ‘s rank after the ith day. We define the rank as :If there are t shops’ price is higher than the “memory” , than its rank is t+1.

包含m行,在第i行中打印商店“记忆”在第i天之后的排名。我们定义秩为:如果有t家商店的价格高于“内存”,其秩为t+1。

Sample Input

3
memory
kfc
wind
2
49 memory
49 kfc
48 wind
80 kfc
85 wind
83 memory

Sample Output

1
2
package com.hhhyixin.book.cp03.hdu_2648;

import java.util.*;

public class Main {
    HashMap<String, Integer> map = new HashMap<>();//用map来存储数据<商店,增长的价格>
    int sum = 1;//记录排名

    public static void main(String[] args) {
        new Main().work();//调主函数方法
    }

    void work() {//方法
        Scanner sc = new Scanner(System.in);
        int n = sc.nextInt();//商店数
        String[] shop = new String[n];
        for (int i = 0; i < n; i++) {

            shop[i] = sc.next();
            map.put(shop[i], 0);
        }
        int m = sc.nextInt();//天数
        for (int i = 0; i < m; i++) {
            for (int j = 0; j < n; j++) {
                int exps = sc.nextInt();//加的价格
                String shop_ = sc.next();//商店名称
                map.put(shop_, map.get(shop_) + exps);//将商店名字和价格总值加入map集合中
            }

            int pmemory = map.get("memory");//memory当天的价格

            Iterator<String> iterator = map.keySet().iterator();//迭代器
            while (iterator.hasNext()) {//循环迭代
                String key = (String) iterator.next();//取出key值
                if (map.get(key) > pmemory) {
                    sum++;//没有价格大于momory的排名就不用往上加,大于的话排名就加1
                }
            }
            System.out.println(sum);
        }
    }
}

image-20220930190933488

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

要什么自行车儿

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值