1119 Pre- and Post-order Traversals(前序+后序)

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences, or preorder and inorder traversal sequences. However, if only the postorder and preorder traversal sequences are given, the corresponding tree may no longer be unique.

Now given a pair of postorder and preorder traversal sequences, you are supposed to output the corresponding inorder traversal sequence of the tree. If the tree is not unique, simply output any one of them.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 30), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first printf in a line Yes if the tree is unique, or No if not. Then print in the next line the inorder traversal sequence of the corresponding binary tree. If the solution is not unique, any answer would do. It is guaranteed that at least one solution exists. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input 1:

7
1 2 3 4 6 7 5
2 6 7 4 5 3 1

Sample Output 1:

Yes
2 1 6 4 7 3 5

Sample Input 2:

4
1 2 3 4
2 4 3 1

Sample Output 2:

No
2 1 3 4

 思路:根据前序和后序的遍历序列,首先找当前子树前序序列的第一个元素,这个值一定是等于后序序列的最后一个值的,然后在后序序列中找当前前序序列的第二个值的位置,只要这个位置不出现在后序序列最后一个值的前面一个值的位置,那么当前状态就是唯一的,若出现在该位,则表明不唯一,那么就把它及其子树随便安置在左子树或者是右子树,放置的前序序列为[prel+1,prer],后序序列为[postl,postr-1]。若是唯一的,则当前根节点的左子树前序序列即为[prel+1,pre+len],后序序列为[postl,i],右子树前序序列为[prel+len+1,prer],后序
序列为[i+1,postr-1]; 

#include<bits/stdc++.h>
using namespace std;

typedef struct node{
	int data;
	struct node *l;
	struct node *r;
}node,*tree;
int n;
vector<int> pre;
vector<int> post;
int flag=1;

tree buildTree(int prel,int prer,int postl,int postr)
{
	tree root;
	root=(tree)malloc(sizeof(node));
	root->data=pre[prel];
	root->l=root->r=NULL;
	if(prel==prer) return root;
	
	int i;
	for(i=postl;post[i]!=pre[prel+1];i++);
	if(postr-i>1){
		int len=i-postl+1;
		root->l=buildTree(prel+1,prel+len,postl,i);
		root->r=buildTree(prel+len+1,prer,i+1,postr-1);
	}else{
		flag=0;
		root->r=buildTree(prel+1,prer,postl,postr-1);//这里是把它丢到右子树去(左子树也可)
	}
	
	return root;
}

void inorder(tree root){
	if(!root) return;
	inorder(root->l);
	if(flag){
		printf("%d",root->data);
		flag=0;
	}else{
		printf(" %d",root->data);
	}
	inorder(root->r);
}
int main(){
	cin>>n;
	for(int i=0;i<n;i++){
		int t;
		cin>>t;
		pre.push_back(t);
	}
	for(int i=0;i<n;i++){
		int t;
		cin>>t;
		post.push_back(t);
	}
	
	tree root=buildTree(0,n-1,0,n-1);
	if(!flag) printf("No\n");
	else printf("Yes\n");
	flag=1;
	inorder(root);
	cout<<endl;
	
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值