PAT 1119 Pre- and Post-order Traversals

1119 Pre- and Post-order Traversals

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences, or preorder and inorder traversal sequences. However, if only the postorder and preorder traversal sequences are given, the corresponding tree may no longer be unique.

Now given a pair of postorder and preorder traversal sequences, you are supposed to output the corresponding inorder traversal sequence of the tree. If the tree is not unique, simply output any one of them.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 30), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first printf in a line Yes if the tree is unique, or No if not. Then print in the next line the inorder traversal sequence of the corresponding binary tree. If the solution is not unique, any answer would do. It is guaranteed that at least one solution exists. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input 1:

7
1 2 3 4 6 7 5
2 6 7 4 5 3 1

Sample Output 1:

Yes
2 1 6 4 7 3 5

Sample Input 2:

4
1 2 3 4
2 4 3 1

Sample Output 2:

No
2 1 3 4

总结:这道题目花了好长的时间看题解,终于算是弄懂了,前路漫漫亦灿灿,加油往前走!!!

代码:

#include <iostream>
#include <vector>
using namespace std;
vector<int> in, pre, post;
bool unique = true;
void getIn(int preLeft, int preRight, int postLeft, int postRight) {
    if(preLeft == preRight) {
        in.push_back(pre[preLeft]);
        return;
    }
    if (pre[preLeft] == post[postRight]) {
        int i = preLeft + 1;
        while (i <= preRight && pre[i] != post[postRight-1]) i++;//在前序中找到和后序的根节点
        if (i - preLeft > 1)//根节点左边有节点
            getIn(preLeft + 1, i - 1, postLeft, postLeft + (i - preLeft - 1) - 1);//遍历左子树 
			//i-preleft-1表示i到pre中间有多少个数 ,本身就是一个数,所以还需要在-1 
        //前两个参数确定前序遍历中左子树的范围,后两个参数确定后序遍历中左子树的范围,为什么是从postleft开始呢?
        //这是因为后序遍历是先访问左子树然后访问右子树的,所以可以确定后序遍历中左子树的范围大小
        else
            unique = false;
        //在访问叶节点的时候,前序遍历是先叶节点上面的根节点,然后在访问两个叶节点,这样假如就只有一个叶节点的话,无法判断这个叶节点的位置
        //后序遍历和前序遍历在只有一个叶节点的时候无法知道位置是一样的道理
        in.push_back(post[postRight]);//在遍历完所有的左子树后把右子树的根节点加上 
        getIn(i, preRight, postLeft + (i - preLeft - 1), postRight - 1);
		//开始遍历右子树 
		//这里有个点需要注意的地方,虽然这里是遍历右子树,这只是相对于根节点来说是右子树,遍历过程还是
		//从这个右子树的左子树开始,遍历完了之后才是右子树 
    }
}
int main() {
    int n;
    scanf("%d", &n);
    pre.resize(n), post.resize(n);
    for (int i = 0; i < n; i++)
        scanf("%d", &pre[i]);
    for (int i = 0; i < n; i++)
        scanf("%d", &post[i]);
    getIn(0, n-1, 0, n-1);
    printf("%s\n%d", unique == true ? "Yes" : "No", in[0]);
    for (int i = 1; i < in.size(); i++)
        printf(" %d", in[i]);
    printf("\n");
    return 0;
}

偶数节点肯定没有唯一的答案,奇数节点之后在完全二叉树的情况下结果才是唯一的(自己推的,应该是对的) 

 

 好好学习,天天向上!

我要考研!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值