模拟——Kalevitch and Chess

本文介绍了一位名为Kalevitch的画家如何通过最少的步骤改变8x8棋盘上的黑白方格,以满足客户定制的棋盘需求。问题的关键在于确定在允许一次行或列全部涂色的情况下,实现特定棋盘状态所需的最少操作次数。
摘要由CSDN通过智能技术生成

Kalevitch and Chess

题面翻译

原棋盘为8行8列的白色棋盘,每次可将一行或一列染成黑色,问至少需要多少次才能将棋盘染成**样例所示棋盘
输入:目标棋盘状态,W表示白,B表示黑
输出:最少操作次数
corrected by:Qingyu(UID:92031)

题目描述

A famous Berland’s painter Kalevitch likes to shock the public. One of his last obsessions is chess. For more than a thousand years people have been playing this old game on uninteresting, monotonous boards. Kalevitch decided to put an end to this tradition and to introduce a new attitude to chessboards.

As before, the chessboard is a square-checkered board with the squares arranged in a $ 8×8 $ grid, each square is painted black or white. Kalevitch suggests that chessboards should be painted in the following manner: there should be chosen a horizontal or a vertical line of 8 squares (i.e. a row or a column), and painted black. Initially the whole chessboard is white, and it can be painted in the above described way one or more times. It is allowed to paint a square many times, but after the first time it does not change its colour any more and remains black. Kalevitch paints chessboards neatly, and it is impossible to judge by an individual square if it was painted with a vertical or a horizontal stroke.

Kalevitch hopes that such chessboards will gain popularity, and he will be commissioned to paint chessboards, which will help him ensure a comfortable old age. The clients will inform him what chessboard they want to have, and the painter will paint a white chessboard meeting the client’s requirements.

It goes without saying that in such business one should economize on everything — for each commission he wants to know the minimum amount of strokes that he has to paint to fulfill the client’s needs. You are asked to help Kalevitch with this task.

输入格式

The input file contains 8 lines, each of the lines contains 8 characters. The given matrix describes the client’s requirements, W character stands for a white square, and B character — for a square painted black.

It is guaranteed that client’s requirments can be fulfilled with a sequence of allowed strokes (vertical/column or horizontal/row).

输出格式

Output the only number — the minimum amount of rows and columns that Kalevitch has to paint on the white chessboard to meet the client’s requirements.

样例 #1

样例输入 #1

WWWBWWBW
BBBBBBBB
WWWBWWBW
WWWBWWBW
WWWBWWBW
WWWBWWBW
WWWBWWBW
WWWBWWBW

样例输出 #1

3

样例 #2

样例输入 #2

WWWWWWWW
BBBBBBBB
WWWWWWWW
WWWWWWWW
WWWWWWWW
WWWWWWWW
WWWWWWWW
WWWWWWWW

样例输出 #2

1

思路

这道题千万别想复杂了(本人刚开始想用bfs来做),我们直接枚举一行/列有B,然后如果满足就ans++。(因为题目貌似是说明不会出现一个B的情况)。

  • 细节1:题目可能出现全为B的情况,因此我们就让ans=8即可。

代码


#include<iostream>
#include<algorithm>
#include<cstring>
#include<queue>

using namespace std;

const int N = 10;

char w[N][N];
int ans;

int main(){
    
    for(int i=1;i<=8;i++){
        for(int j=1;j<=8;j++){
            cin>>w[i][j];
        }
    }
    
    for(int i=1;i<=8;i++){
        bool f=true;
        for(int j=1;j<=8;j++){
            if(w[i][j]!='B'){
                f=false;
                break;
            }
        }
        if(f){
            ans++;
        }
    }
    
    
    for(int i=1;i<=8;i++){
        bool f=true;
        for(int j=1;j<=8;j++){
            if(w[j][i]!='B'){
                f=false;
                break;
            }
        }
        if(f){
            ans++;
        }
    }
    
    if(ans==16)ans=8;
    
    cout<<ans;
    
    return 0;
    
}
  • 26
    点赞
  • 29
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

green qwq

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值