模拟——IQ test

IQ test

题面翻译

题目描述

B o b Bob Bob 准备参加 R P RP RP 测试。他需要从 n n n 个数字中找出一个奇偶性不同的数字。你需要帮助他检查答案。

输入格式

第一行, n n n 3 ≤ n ≤ 100 3\leq n \leq100 3n100);

第二行, n n n 个数字,以空格分开(保证有唯一解)。

输出格式

仅一行,奇偶性不同的数字在原序列中是第几位(从 1 1 1 开始编号)。

题目描述

Bob is preparing to pass IQ test. The most frequent task in this test is to find out which one of the given $ n $ numbers differs from the others. Bob observed that one number usually differs from the others in evenness. Help Bob — to check his answers, he needs a program that among the given $ n $ numbers finds one that is different in evenness.

输入格式

The first line contains integer $ n $ ( $ 3<=n<=100 $ ) — amount of numbers in the task. The second line contains $ n $ space-separated natural numbers, not exceeding 100. It is guaranteed, that exactly one of these numbers differs from the others in evenness.

输出格式

Output index of number that differs from the others in evenness. Numbers are numbered from 1 in the input order.

样例 #1

样例输入 #1

5
2 4 7 8 10

样例输出 #1

3

样例 #2

样例输入 #2

4
1 2 1 1

样例输出 #2

2

代码

#include<iostream>
#include<algorithm>

using namespace std;

const int N = 110;

int w[N],n;

int main(){
    cin>>n;
    
    int ji=0,ou=0;
    for(int i=1;i<=n;i++){
        cin>>w[i];
        if(w[i]&1)ji++;
        else ou++;
    }
    
    if(ji==1){
        for(int i=1;i<=n;i++){
            if(w[i]&1){
                cout<<i;
                break;
            }
        }
    }else{
        for(int i=1;i<=n;i++){
            if(!(w[i]&1)){
                cout<<i;
                break;
            }
        }
    }
    return 0;
}
  • 24
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

green qwq

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值