1004 Counting Leaves(dfs):邻接表版:写的太多了

81 篇文章 0 订阅

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

代码

//就是找叶子节点数,然后每一层输出

#include<iostream>
#include<cstring>
#include<algorithm>

using namespace std;

const int N = 110*110,M = 2*N;

int e[M],ne[M],h[N],idx;
bool st[N];
int depth[N];
int n,m;
int f[N];
int res;

void add(int a,int b){
    e[idx]=b,ne[idx]=h[a],h[a]=idx++;
}

void dfs(int u,int fa){
    for(int i=h[u];~i;i=ne[i]){
        int j=e[i];
        if(j==fa)continue;
        depth[j]=depth[u]+1;
        if(j==0){
            f[depth[u]]++;
            return;
        }
        dfs(j,u);
        res=max(res,depth[j]);
    }
}

int main(){
    cin>>n>>m;

    memset(h,-1,sizeof h);

    for(int i=1;i<=m;i++){
        int root,k;
        cin>>root>>k;
        st[root]=true;
        while(k--){
            int x;
            cin>>x;
            add(root,x);
            add(x,root);
        }
    }
    
    if(!m){
        cout<<n<<endl;
        return 0;
    }
    
    for(int i=1;i<=n;i++){
        if(!st[i]){
            add(i,0);
            add(0,i);
        }
    }
    
    depth[1]=1;
    dfs(1,-1);
    for(int i=1;i<res;i++){
        cout<<f[i]<<' ';
    }

    cout<<f[res];

    return 0;
}
  • 28
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

green qwq

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值