1016 Phone Bills/电话账单
A long-distance telephone company charges its customers by the following rules:
Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.
Input Specification:
Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.
The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.
The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word on-line or off-line.
For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-line record. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.
Output Specification:
For each test case, you must print a phone bill for each customer.
Bills must be printed in alphabetical order of customers’ names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.
Sample Input:
10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line
Sample Output:
CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80
思路
我们可以用 map 容器来装,map容器堆存储的第一维度会自动从小到大排序,然后我们的第二维度就是存储这个人的日期年份和状态,然后存完我们就枚举每一个人,然后先对日期进行排序,然后看前一个状态和后一个状态是否匹配,如果匹配,我们就计算。
代码
//大模拟题
#include<iostream>
#include<algorithm>
#include<cstring>
#include<vector>
#include<map>
using namespace std;
const int N = 1010,M = 31*1440+10;
struct E{
int minv;
string state;
string k;
bool operator<(const E& t)const{
return minv<t.minv;
}
}e[N];
int w[N];//收费
int n;
map<string,vector<E>> S;
double s[M];
int aut(string x){
int res=0;
for(int i=0;i<x.size();i++){
res=(res<<3)+(res<<1)+x[i]-'0';
}
return res;
}
int main(){
for(int i=0;i<24;i++){
cin>>w[i];
}
for(int i=1;i<M;i++){
s[i]=s[i-1]+w[(i-1)%1440/60]/100.0;
}
cin>>n;
int mon,day,h,m;
for(int i=1;i<=n;i++){
string a,state,k;
cin>>a;
// scanf("%d:%d:%d:%d",&mon,&day,&h,&m);
cin>>k;
mon=aut(k.substr(0,2));
day=aut(k.substr(3,2));
h=aut(k.substr(6,2));
m=aut(k.substr(9,2));
cin>>state;
int ms;
ms=(day-1)*1440+h*60+m;
S[a].push_back({ms,state,k});
}
for(auto [name,recorde]:S){
sort(recorde.begin(),recorde.end());
double t=0;
for(int i=0;i<recorde.size()-1;i++){
auto a=recorde[i],b=recorde[i+1];
if(a.state=="on-line"&&b.state=="off-line"){
if(!t)cout<<name,printf(" %02d\n",mon);
cout<<a.k.substr(3)<<' '<<b.k.substr(3);
double c=s[b.minv]-s[a.minv];
printf(" %d $%.2lf\n",b.minv-a.minv,c);
t+=c;
}
}
if(t)printf("Total amount: $%.2lf\n", t);
}
return 0;
}
个人感觉自己写的太麻烦了。