1016 Phone Bills (25分)--PAT甲级真题

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:
Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word on-line or off-line.

For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-line record. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:
For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers’ names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

题目大意:给出24小时各个时间段的通话费用,并且给出通话记录;要求按照要求打印电话单;

分析:完成这个题目,主要有两个要注意的点;第一,电话记录可能是不成对的,也就是有无用的电话记录,off-line要和其最近的on-line配对;第二,给出了一次通话的开始时间还有结束时间,如何计算这次通话的费用;

针对第一个点,使得通话记录按照用户姓名来排序,内部再按照时间点来排序;之后遍历通话记录,必须要是同一个用户,并且依次是on-line和off-line的状态,才是依次合法的通话记录;

针对第二点,假设开始时间s,结束时间e(换算成秒为单位);只要计算其间的每一秒属于什么时间段,加上相应时间段的费用即可;

#include<iostream>
#include<vector>
#include<string> 
#include<algorithm> 
using namespace std; 
struct CallRec{
	string ID;
	int mo,t, flag;
};  
bool cmp(const CallRec& A, const CallRec& B) { return A.ID == B.ID ? A.t < B.t : A.ID < B.ID; }
vector<CallRec> vCallRec; 
int cost[25]; 
int calCost(CallRec s, CallRec e){
	int ret = 0; 
	for (int i = s.t; i < e.t; i++) {
		int h = i % (60 * 24) / 60;
		ret += cost[h]; 
	} 
	return ret;
} 
int main(){
	int N;
	for (int i = 0; i <= 23; i++)
		scanf("%d", &cost[i]);
	scanf("%d", &N);
	for (int i = 0; i < N; i++){
		int mo, dd, hh, mi;
		CallRec Rec;
		string status;
		cin >> Rec.ID;
		scanf("%d:%d:%d:%d", &mo, &dd, &hh, &mi);
		cin >> status;
		Rec.mo = mo;
		Rec.t = dd * 24 * 60 + hh * 60 + mi; 
		Rec.flag = status == "on-line" ? 1 : -1;
		vCallRec.push_back(Rec);
	} 
	sort(vCallRec.begin(), vCallRec.end(), cmp); 
	string lastID;
	int lastTotal;
	for (int i = 0; i < N - 1; i++){
		if (vCallRec[i].ID == vCallRec[i + 1].ID && 
			vCallRec[i].flag == 1 && vCallRec[i + 1].flag == -1){ 
			if (vCallRec[i].ID != lastID) {
				if(lastID!="")
					printf("Total amount: $%.2f\n", lastTotal/100.00);
				printf("%s %02d\n", vCallRec[i].ID.c_str(), vCallRec[i].mo);
				lastID = vCallRec[i].ID;
				lastTotal = 0;
			}
			int c = calCost(vCallRec[i], vCallRec[i + 1]);
			lastTotal += c;
			printf("%02d:%02d:%02d %02d:%02d:%02d %d $%.2f\n", vCallRec[i].t/(24*60), (vCallRec[i].t%(24 * 60))/60, vCallRec[i].t%60,
				vCallRec[i+1].t/(24*60), (vCallRec[i+1].t%(24*60))/60, vCallRec[i+1].t%60, 
				vCallRec[i + 1].t - vCallRec[i].t, c/100.00);
		} 
	}   
	printf("Total amount: $%.2f\n", lastTotal/100.00);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值