信息奥赛课课通(C++) 打印图形III

由键盘输入任意一个自然数N,输出如下图规律的图形。
 

输入

只有一个整数N,为图形上半部分的行数(其中2≤N≤26)

输出

输出指定格式图形。

样例输入 Copy

4

样例输出 Copy

D      D
CD    DC
BCD  DCB
ABCDDCBA
BCD  DCB
CD    DC
D      D

 代码

#include<iostream>
#include<cmath>
using namespace std;
int main(){
    int n,i,j,q=1,w;
    cin>>n;
    w=n;
    for(i=0;i<n;i++){
        for(j=0;j<q;j++){
            cout<<(char)(64+(n-i+j));
        }
        for(j=0;j<w+(n-2);j++){
            cout<<" ";
        }
        for(j=0;j<q;j++){
            cout<<(char)(64+(n-j));
        }
        q++;
        w=w-2;
        cout<<endl;
    }
    q=n-1;
    w=2;
    for(i=i;i>1;i--){
        for(j=2;j<=q+1;j++){
            cout<<(char)(64+(n-i+j));
        }
        for(j=0;j<w;j++){
            cout<<" ";
        }
        for(j=0;j<q;j++){
            cout<<(char)(64+n-j);
        }
        w=w+2;
        q--;
        cout<<endl;
    }
    return 0;
}
 


#include<iostream>
#include<cmath>
using namespace std;
int main(){
    int n,i,j,q=1,w;
    cin>>n;
    w=n;
    for(i=0;i<n;i++){
        for(j=0;j<q;j++){
            cout<<(char)(64+(n-i+j));
        }
        for(j=0;j<w+(n-2);j++){
            cout<<" ";
        }
        for(j=0;j<q;j++){
            cout<<(char)(64+(n-j));
        }
        q++;
        w=w-2;
        cout<<endl;
    }
    q=n-1;
    w=2;
    for(i=i;i>1;i--){
        for(j=2;j<=q+1;j++){
            cout<<(char)(64+(n-i+j));
        }
        for(j=0;j<w;j++){
            cout<<" ";
        }
        for(j=0;j<q;j++){
            cout<<(char)(64+n-j);
        }
        w=w+2;
        q--;
        cout<<endl;
    }
    return 0;
}

  • 3
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

小宸1145145

可怜可怜我这个人吧~

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值