04-二叉平衡树1 Root of AVL Tree

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the root of the resulting AVL tree in one line.

Sample Input 1:

5
88 70 61 96 120

Sample Output 1:

70

Sample Input 2:

7
88 70 61 96 120 90 65

Sample Output 2:

88
题意:将输入调整为平衡二叉树,输出根结点元素
#include <iostream>
#include <cstdlib>
using namespace std;

typedef struct AVLTree{
    int data;
    AVLTree *left;
    AVLTree *right;
    int height;
}AVLTree;

int max(int a,int b)
{
    return a>b?a:b;
}

int GetHeight(AVLTree *T)
{
    if(!T)
    {
        return 0;
    }
    else
    {
        return T->height;
    }
}

AVLTree *SingleLeftRotation(AVLTree *A)//左单旋
{
    AVLTree *B = A->left;
    A->left = B->right;
    B->right = A;
    A->height = max(GetHeight(A->left),GetHeight(A->right))+1;
    B->height = max(GetHeight(B->left), A->height)+1;
    return B;
}

AVLTree *SingleRightRotation(AVLTree *A)//右单旋
{
    AVLTree *B = A->right;
    A->right = B->left;
    B->left = A;
    A->height = max(GetHeight(A->right),GetHeight(A->left))+1;
    B->height = max(GetHeight(B->right), A->height)+1;
    return B;
}

AVLTree *DoubleLeftRightRotation(AVLTree *A)//左右双旋
{
    A->left = SingleRightRotation(A->left);
    return SingleLeftRotation(A);
}

AVLTree *DoubleRightLeftRotation(AVLTree *A)//右左双旋
{
    A->right = SingleLeftRotation(A->right);
    return SingleRightRotation(A);
}

AVLTree *Insert(AVLTree *T,int x)//插入
{
    if(!T)
    {
        T = (AVLTree *)malloc(sizeof(AVLTree));
        T->data = x;
        T->height = 1;
        T->left = T->right = NULL;
    }
    else if(x < T->data)
    {
        T->left = Insert(T->left,x);
        if(GetHeight(T->left)-GetHeight(T->right)==2)
        {
            if(x < T->left->data)
            {
                T = SingleLeftRotation(T);
            }
            else
            {
                T = DoubleLeftRightRotation(T);
            }
        }
    }
    else if(x > T->data)
    {
        T->right = Insert(T->right,x);
        if(GetHeight(T->left)-GetHeight(T->right)== -2)
        {
            if(x > T->right->data)
            {
                T = SingleRightRotation(T);
            }
            else
            {
                T = DoubleRightLeftRotation(T);
            }
        }
    }
    
    T->height = max(GetHeight(T->left),GetHeight(T->right))+1;
    return T;
}

int main()
{
    int n,x;
    cin >> n;
    AVLTree *T = NULL;
    for(int i = 0;i < n;i++)
    {
        cin >> x;
        T = Insert(T,x);
    }
    cout << T->data;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值