Catch That Cow

                                                          Catch That Cow

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 191205Accepted: 58049

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

题目大意:
农夫在直线上N点,奶牛在直线上的K点,奶牛不能移动,农夫去找丢失的奶牛,农夫每次可以在一分钟内行走或者传送一次

规则如下:

行走:从x点到x+1或者x-1

传送:从x点传送到x*2

求用最少时间找到丢失的奶牛。

思路如下: 

这是一道bfs题目,不知道的可以去查,这里就不多解释了,农夫每一分钟有三种方法,创建一个队列,将起始点N放入队列,再将三种方法后的点输入队列,时间加1,不断的循环下去,直到找到奶牛为止,返回所用的最短时间就可以了。

代码:

#include<iostream>
#include<queue>
using namespace std;
int arr[100005];
int n,k;
int step[100005];
int bfs(int a)
{
	arr[a]=1;
	queue<int>q;//创建一个队列
	q.push(a);//将农夫的起始点放进队列中
	step[a]=0;//初始时间为零
	while(!q.empty())//如果队列不为空就一直循环下去
	{
		int xx=q.front();//访问首元素
		q.pop();//将首元素弹出
		int next;
		for(int i=0;i<3;i++)//三种方法到下一个点
		{
			if(i==0)
			{
				next=xx-1;//x到x-1
			}
			if(i==1)
			{
				next=xx+1;//x到x+1
			}
			if(i==2)
			{
				next=xx*2;//x到x*2
			}
			if(next>=0&&next<100005&&arr[next]==0)//如果下一个点没有越界,就把这个点放入队列
			{
				q.push(next);
			    step[next]=step[xx]+1;//时间加1
			    arr[next]=1;
			}
			if(next==k)//如果找到奶牛,返回总时间
	    	{
    	    	return step[next];
        	}
		}
	}
}
int main()
{
	cin>>n>>k;
	if(n>=k)
	{
		cout<<n-k; 
	}
	else
	{
		int sum=bfs(n);
     	cout<<sum;
	}
	return 0;
}

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值