zcmu-1313: The Balance(vector)

Description

Now you are asked to measure a dose of medicine with a balance and a number of weights. Certainly it is not always achievable. So you should find out the qualities which cannot be measured from the range [1,S]. S is the total quality of all the weights.

Input

The input consists of multiple test cases, and each case begins with a single positive integer N (1<=N<=100) on a line by itself indicating the number of weights you have. Followed by N integers Ai (1<=i<=N), indicating the quality of each weight where 1<=Ai<=100.

Output

For each input set, you should first print a line specifying the number of qualities which cannot be measured. Then print another line which consists all the irrealizable qualities if the number is not zero.

Sample Input

3

1 2 4

3

9 2 1

Sample Output

0

2

4 5

代码:

#include<bits/stdc++.h>
using namespace std;
vector<int>vi;
int s[10005];
int t,n,x,sum;
int main(){
	while(~scanf("%d",&n)){
			sum=0;
			memset(s,0,sizeof(s));
			for(int i=0;i<n;i++){
				scanf("%d",&x);
				sum+=x;
				int w=vi.size();
				if(s[x]==0){
					vi.push_back(x);
					s[x]++;
				}
				for(int y=0;y<w;y++){
					int a=abs(vi[y]+x);
					int b=abs(vi[y]-x);
					if(s[a]==0&&a>0)vi.push_back(a),s[a]++;
					if(s[b]==0&&b>0)vi.push_back(b),s[b]++;
				}
			}
			int num=vi.size();
			printf("%d\n",sum-num);
			int w=1;
			for(int i=1;i<=sum;i++){
				if(s[i]==0){
					if(w<sum-num){
						printf("%d ",i);
					}
					else if(w==sum-num){
						printf("%d\n",i);
					}
					w++;
				}
			}
			vi.clear();
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

emo的鱼香roise

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值