The Balance(扩展欧几里得算法)

Description

Ms. Iyo Kiffa-Australis has a balance and only two kinds of weights to measure a dose of medicine. For example, to measure 200mg of aspirin using 300mg weights and 700mg weights, she can put one 700mg weight on the side of the medicine and three 300mg weights on the opposite side (Figure 1). Although she could put four 300mg weights on the medicine side and two 700mg weights on the other (Figure 2), she would not choose this solution because it is less convenient to use more weights. 
You are asked to help her by calculating how many weights are required. 

Input

The input is a sequence of datasets. A dataset is a line containing three positive integers a, b, and d separated by a space. The following relations hold: a != b, a <= 10000, b <= 10000, and d <= 50000. You may assume that it is possible to measure d mg using a combination of a mg and b mg weights. In other words, you need not consider "no solution" cases. 
The end of the input is indicated by a line containing three zeros separated by a space. It is not a dataset.

Output

The output should be composed of lines, each corresponding to an input dataset (a, b, d). An output line should contain two nonnegative integers x and y separated by a space. They should satisfy the following three conditions. 
  • You can measure dmg using x many amg weights and y many bmg weights. 
  • The total number of weights (x + y) is the smallest among those pairs of nonnegative integers satisfying the previous condition. 
  • The total mass of weights (ax + by) is the smallest among those pairs of nonnegative integers satisfying the previous two conditions.

No extra characters (e.g. extra spaces) should appear in the output.

Sample Input

700 300 200
500 200 300
500 200 500
275 110 330
275 110 385
648 375 4002
3 1 10000
0 0 0

Sample Output

1 3
1 1
1 0
0 3
1 1
49 74
3333 1


题目大意:

给定 a,b,c 找到满足ax+by=c的x,y并且使得|x|+|y|的值最小。


解题思路:

方程ax+by=c的一组解x0,y0可以用扩展欧几里得算法求,那么方程ax+by=c的所有x,y可以表示为x=x0+b/d *t ,y=y0-a/d *t(t为整数,d是a和b的最大公约数)。所以求|x|+|y|的最小值即是求f(t)=|x0+b/d *t |+|y0-a/d *t|这个关于t的函数的最小值,很显然在y=y0-a/d*t的零点附近取到(因为要求t为整数),于是在  y0*d/a 附近的两整点里取,最小的即是结果。



代码如下:C/C++

#include<stdio.h>
#include<stdlib.h>
#include<iostream>
using namespace std;
//扩展欧几里德算法求方程ax+by=gcd(a,b)的一组整数解x0,y0和gcd(a,b)
int exgcd(int a,int b,int &x0,int &y0)
{
    int d,t;
    if(b==0)
    {
        x0=1;
        y0=0;
        return a;
    }
    d=exgcd(b,a%b,x0,y0);
    t=x0;
    x0=y0;
    y0=t-a/b*y0;
    return d;
}
int main()
{
    int a,b,c,d,x,y,x0,y0,x1,y1,i,flag,t,min;
    while(scanf("%d%d%d",&a,&b,&c)!=EOF)
    {
        if(a==0&&b==0&&c==0)
             break;
        flag=0;//判断a,b是否交换
        if(a<b)//确保a>=b
        {
            flag=1;
            swap(a,b);
        }
        d=exgcd(a,b,x0,y0);//求出方程ax+by=gcd(a,b)的一组整数解x0,y0和gcd(a,b)
        //求出方程Ax+By=c的一组整数解x0,y0
        x0=x0*(c/d);
        y0=y0*(c/d);
        t=y0/(a/d);//求出满足|x|+|y|最小的可能的t
        //初始化最优解
        min=abs(x0)+abs(y0);
        x1=abs(x0);
        y1=abs(y0);
        //在t点附近查找最优解
        for(i=t-1;i<=t+1;i++)
        {
            x=x0+b/d*i;
            y=y0-a/d*i;
            if(abs(x)+abs(y)<min)
            {
                min=abs(x)+abs(y);
                x1=abs(x);
                y1=abs(y);
            }
        }
        //若前面交换了a,b的值,则交换x1,y1的值
        if(flag)
            swap(x1,y1);
        printf("%d %d\n",x1,y1);
    }
    return 0;
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值