自测-4 Have Fun with Numbers (20 分)

自测-4 Have Fun with Numbers (20 分)

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

AC代码:
 

#include <bits/stdc++.h>
using namespace std;
int c[10], b[22], a[22];

int main() {
	string s;
	int t = 0;
	cin >> s;
	for (int i = 1; i <= s.size(); i++) {
		a[i] = s[i - 1] - '0';
		c[a[i]]++;
	}
	for (int i = s.size(); i > 0; i--) {
		b[i] = b[i] + 2 * a[i] + t;
		t = b[i] / 10;
		b[i] = b[i] % 10;
		c[b[i]]--;
	}
	if (t > 0) {
		b[0] = t;
		c[t]++;
	}
	int i;
	for (i = 0; i < 10; i++) {
		if (c[i] != 0) {
			cout << "No" << endl;
			break;
		}
	}
	if (i == 10)
		cout << "Yes" << endl;
	if (b[0])
		cout << b[0];
	for (int i = 1; i <= s.size(); i++)
		cout << b[i];
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值