River Hopscotch(二分查找)

Every year the cows hold an event featuring a peculiar version of
hopscotch that involves carefully jumping from rock to rock in a
river. The excitement takes place on a long, straight river with a
rock at the start and another rock at the end, L units away from the
start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting
and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an
integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and
tries to reach the finish at the ending rock, jumping only from rock
to rock. Of course, less agile cows never make it to the final rock,
ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But
as time goes by, he tires of watching the timid cows of the other
farmers limp across the short distances between rocks placed too
closely together. He plans to remove several rocks in order to
increase the shortest distance a cow will have to jump to reach the
end. He knows he cannot remove the starting and ending rocks, but he
calculates that he has enough resources to remove up to M rocks (0 ≤ M
≤ N).

FJ wants to know exactly how much he can increase the shortest
distance before he starts removing the rocks. Help Farmer John
determine the greatest possible shortest distance a cow has to jump
after removing the optimal set of M rocks.

Input
Line 1: Three space-separated integers: L, N, and M Lines
2…N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output
Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks

Sample Input
25 5 2
2
14
11
21
17
Sample Output
4

Hint
Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).

题意: 第一行输入河得宽度L,河中的石头数量N,和要去掉的石头M,接下来输入N行为当前河中石头的位置。
输出:去掉任意M块石头后,假设有n种可能,n组中石头间最小距离的最大值。

#include<iostream>
#include<cstring>
#include<cstdio>
#include<queue>
#include<map>
#include<algorithm>
#define ll long long
const ll inf = 0x3f3f3f3f3f3f3f3f;//表示无穷大
using namespace std;
ll num[50005],L, N, M;
ll work(ll l, ll r) {
	while (l <= r) {
		ll mid = l + r >> 1;
		ll x = num[0], number = 0;//用来记入上一块石头的位置,number表示被删去的石头
		for (int i = 1; i < N; i++) {
			if (num[i] - x >= mid) {
				x = num[i];//如果与前一块保留的石头的距离不小于mid则这块石头需要保留,并对x重新赋值
			}
			else {
				number++;//如果距离比mid要小,则删除这块石头
			}
		}
		if (number > M) {
			r = mid-1;//如果删掉的石头偏多则小缩小石头间的距离
		}
		else {
			l = mid + 1;//如果删掉的石头小于应该删掉的石头则增大石头间的距离
			//如果删掉的石头已经和应该删掉的石头相等了那么要继续往右寻找最长可满足条件的长度
		}
	}
	return r;//返回最大的最短距离
}
int main() {
	ios::sync_with_stdio(false);
	cin.tie(0);
	cin >> L >> N >> M;
	num[0] = 0, num[N + 1] = L;
	for (int i = 1; i <= N; i++) {
		cin >> num[i];
	}
	N += 2;//work函数中要算上起点和尾点
	sort(num, num + N);//这一步排序不能忘!!
	ll ans = inf;
	for (int i = 1; i < N; i++) {
		ans = min(ans, num[i] - num[i - 1]);//其实就是在寻找确定 left的位置
	}
	ll result = work(ans, L);
	printf("%lld\n", result);
}

小知识:cout不能输出long long 的数据类型,铁子哥说 在读long long 数据类型时 cin 比 scanf 要快。

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值