IPV6与IPV4共存实验

实验拓扑

在这里插入图片描述
在这里插入图片描述

实验要求

在这里插入图片描述

实验配置

R1

<Huawei>dis current-configuration 
[V200R003C00]
#
 snmp-agent local-engineid 800007DB03000000000000
 snmp-agent 
#
 clock timezone China-Standard-Time minus 08:00:00
#
portal local-server load portalpage.zip
#
 drop illegal-mac alarm
#
ipv6 
#
 set cpu-usage threshold 80 restore 75
#
aaa 
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default 
 domain default_admin 
 local-user admin password cipher %$%$K8m.Nt84DZ}e#<0`8bmE3Uw}%$%$
 local-user admin service-type http
#
firewall zone Local
 priority 15
#
interface GigabitEthernet0/0/0
 ipv6 enable 
 ip address 12.1.1.1 255.255.255.252 
 ipv6 address 2002:1701:101:4::1/64 
 ripng 1 enable
#
interface GigabitEthernet0/0/1
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
interface LoopBack0
 ipv6 enable 
 ip address 1.1.1.1 255.255.255.0 
 ipv6 address 2002:1701:101:2::1/64 
 ripng 1 enable
#
interface LoopBack1
 ipv6 enable 
 ip address 1.1.2.1 255.255.255.0 
 ipv6 address 2002:1701:101:3::1/64 
 ripng 1 enable
#
ripng 1
#
ip route-static 0.0.0.0 0.0.0.0 12.1.1.2
ip route-static 1.1.0.0 255.255.0.0 NULL0
#
user-interface con 0
 authentication-mode password
user-interface vty 0 4
user-interface vty 16 20
#
wlan ac
#
return

R2

<Huawei>dis current-configuration 
[V200R003C00]
#
 snmp-agent local-engineid 800007DB03000000000000
 snmp-agent 
#
 clock timezone China-Standard-Time minus 08:00:00
#
portal local-server load portalpage.zip
#
 drop illegal-mac alarm
#
ipv6 
#
 set cpu-usage threshold 80 restore 75
#
acl number 2000  
 rule 5 permit 
#
aaa 
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default 
 domain default_admin 
 local-user admin password cipher %$%$K8m.Nt84DZ}e#<0`8bmE3Uw}%$%$
 local-user admin service-type http
#
firewall zone Local
 priority 15
#
interface GigabitEthernet0/0/0
 ipv6 enable 
 ip address 12.1.1.2 255.255.255.252 
 ipv6 address 2002:1701:101:4::2/64 
 ripng 1 enable
 ripng default-route only
#
interface GigabitEthernet0/0/1
 ipv6 enable 
 ip address 23.1.1.1 255.255.255.252 
 nat outbound 2000
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
interface LoopBack0
 ipv6 enable 
 ip address 2.2.2.2 255.255.255.0 
 ipv6 address 2002:1701:101:5::1/64 
 ripng 1 enable
#
interface Tunnel0/0/1
 ipv6 enable 
 ipv6 address 2002:1701:101:1::1/64 
 tunnel-protocol ipv6-ipv4 6to4
 source 23.1.1.1
#
ripng 1
#
ip route-static 0.0.0.0 0.0.0.0 23.1.1.2
ip route-static 1.1.0.0 255.255.0.0 12.1.1.1
#
ipv6 route-static 2002:: 16 Tunnel0/0/1 
#
user-interface con 0
 authentication-mode password
user-interface vty 0 4
user-interface vty 16 20
#
wlan ac
#
return

R3

<Huawei>dis cu
[V200R003C00]
#
 snmp-agent local-engineid 800007DB03000000000000
 snmp-agent 
#
 clock timezone China-Standard-Time minus 08:00:00
#
portal local-server load portalpage.zip
#
 drop illegal-mac alarm
#
 set cpu-usage threshold 80 restore 75
#
aaa 
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default 
 domain default_admin 
 local-user admin password cipher %$%$K8m.Nt84DZ}e#<0`8bmE3Uw}%$%$
 local-user admin service-type http
#
firewall zone Local
 priority 15
#
interface GigabitEthernet0/0/0
 ip address 23.1.1.2 255.255.255.252 
#
interface GigabitEthernet0/0/1
 ip address 34.1.1.1 255.255.255.252 
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
interface LoopBack0
 ip address 3.3.3.3 255.255.255.255 
#
user-interface con 0
 authentication-mode password
user-interface vty 0 4
user-interface vty 16 20
#
wlan ac
#
return

R4

<Huawei>dis cu
[V200R003C00]
#
 snmp-agent local-engineid 800007DB03000000000000
 snmp-agent 
#
 clock timezone China-Standard-Time minus 08:00:00
#
portal local-server load portalpage.zip
#
 drop illegal-mac alarm
#
ipv6 
#
 set cpu-usage threshold 80 restore 75
#
aaa 
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default 
 domain default_admin 
 local-user admin password cipher %$%$K8m.Nt84DZ}e#<0`8bmE3Uw}%$%$
 local-user admin service-type http
#
firewall zone Local
 priority 15
#
interface GigabitEthernet0/0/0
 ipv6 enable 
 ip address 34.1.1.2 255.255.255.252 
#
interface GigabitEthernet0/0/1
 ipv6 enable 
 ipv6 address 2002:2201:102:2::1/64 
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
interface LoopBack0
 ipv6 enable 
 ipv6 address 2002:2201:102:3::1/64 
#
interface Tunnel0/0/1
 ipv6 enable 
 ipv6 address 2002:2201:102:1::1/64 
 tunnel-protocol ipv6-ipv4 6to4
 source 34.1.1.2
#
bgp 1
 router-id 4.4.4.4
 peer 2002:2201:102:2::2 as-number 2 
 #
 ipv4-family unicast
  undo synchronization
 #
 ipv6-family unicast
  undo synchronization
  network 2002:: 16 
  network 2002:2201:102:3:: 64 
  peer 2002:2201:102:2::2 enable
#
ip route-static 0.0.0.0 0.0.0.0 34.1.1.1
#
ipv6 route-static 2002:: 16 Tunnel0/0/1 
#
user-interface con 0
 authentication-mode password
user-interface vty 0 4
user-interface vty 16 20
#
wlan ac
#
return

R5

<Huawei>dis cu
[V200R003C00]
#
 snmp-agent local-engineid 800007DB03000000000000
 snmp-agent 
#
 clock timezone China-Standard-Time minus 08:00:00
#
portal local-server load portalpage.zip
#
 drop illegal-mac alarm
#
ipv6 
#
 set cpu-usage threshold 80 restore 75
#
aaa 
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default 
 domain default_admin 
 local-user admin password cipher %$%$K8m.Nt84DZ}e#<0`8bmE3Uw}%$%$
 local-user admin service-type http
#
ospfv3 1
 router-id 5.5.5.5
 default-route-advertise
#
firewall zone Local
 priority 15
#
interface GigabitEthernet0/0/0
 ipv6 enable 
 ipv6 address 2002:2201:102:2::2/64 
 ospfv3 1 area 0.0.0.0
#
interface GigabitEthernet0/0/1
 ipv6 enable 
 ipv6 address 2002:2201:102:5::1/64 
 ospfv3 1 area 0.0.0.0
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
interface LoopBack0
 ipv6 enable 
 ipv6 address 2002:2201:102:4::1/64 
 ospfv3 1 area 0.0.0.0
#
bgp 64512
 router-id 5.5.5.5
 confederation id 2
 peer 2002:2201:102:2::1 as-number 1 
 peer 2002:2201:102:6::1 as-number 64512 
 peer 2002:2201:102:6::1 connect-interface LoopBack0
 #
 ipv4-family unicast
  undo synchronization
 #
 ipv6-family unicast
  undo synchronization
  import-route ospfv3 1
  peer 2002:2201:102:2::1 enable
  peer 2002:2201:102:6::1 enable
  peer 2002:2201:102:6::1 next-hop-local 
#
user-interface con 0
 authentication-mode password
user-interface vty 0 4
user-interface vty 16 20
#
wlan ac
#
return

R6

<Huawei>dis cu
[V200R003C00]
#
 snmp-agent local-engineid 800007DB03000000000000
 snmp-agent 
#
 clock timezone China-Standard-Time minus 08:00:00
#
portal local-server load portalpage.zip
#
 drop illegal-mac alarm
#
ipv6 
#
 set cpu-usage threshold 80 restore 75
#
aaa 
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default 
 domain default_admin 
 local-user admin password cipher %$%$K8m.Nt84DZ}e#<0`8bmE3Uw}%$%$
 local-user admin service-type http
#
ospfv3 1
 router-id 6.6.6.6
#
firewall zone Local
 priority 15
#
interface GigabitEthernet0/0/0
 ipv6 enable 
 ipv6 address 2002:2201:102:5::2/64 
 ospfv3 1 area 0.0.0.0
#
interface GigabitEthernet0/0/1
 ipv6 enable 
 ipv6 address 2002:2201:102:7::1/64 
 ospfv3 1 area 0.0.0.0
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
interface LoopBack0
 ipv6 enable 
 ipv6 address 2002:2201:102:6::1/64 
 ospfv3 1 area 0.0.0.0
#
bgp 64512
 router-id 6.6.6.6
 confederation id 2
 peer 2002:2201:102:4::1 as-number 64512 
 peer 2002:2201:102:4::1 connect-interface LoopBack0
 peer 2002:2201:102:9::1 as-number 64512 
 peer 2002:2201:102:9::1 connect-interface LoopBack0
 #
 ipv4-family unicast
  undo synchronization
 #
 ipv6-family unicast
  undo synchronization
  peer 2002:2201:102:4::1 enable
  peer 2002:2201:102:4::1 reflect-client
  peer 2002:2201:102:9::1 enable
#
user-interface con 0
 authentication-mode password
user-interface vty 0 4
user-interface vty 16 20
#
wlan ac
#
return

R7

<Huawei>dis cu
[V200R003C00]
#
 snmp-agent local-engineid 800007DB03000000000000
 snmp-agent 
#
 clock timezone China-Standard-Time minus 08:00:00
#
portal local-server load portalpage.zip
#
 drop illegal-mac alarm
#
ipv6 
#
 set cpu-usage threshold 80 restore 75
#
aaa 
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default 
 domain default_admin 
 local-user admin password cipher %$%$K8m.Nt84DZ}e#<0`8bmE3Uw}%$%$
 local-user admin service-type http
#
ospfv3 1
 router-id 7.7.7.7
#
firewall zone Local
 priority 15
#
interface GigabitEthernet0/0/0
 ipv6 enable 
 ipv6 address 2002:2201:102:7::2/64 
 ospfv3 1 area 0.0.0.0
#
interface GigabitEthernet0/0/1
 ipv6 enable 
 ipv6 address 2002:2201:102:8::1/64 
 ospfv3 1 area 0.0.0.0
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
interface LoopBack0
 ipv6 enable 
 ipv6 address 2002:2201:102:9::1/64 
 ospfv3 1 area 0.0.0.0
#
bgp 64512
 router-id 7.7.7.7
 confederation id 2
 confederation peer-as 64513
 peer 2002:2201:102:6::1 as-number 64512 
 peer 2002:2201:102:6::1 connect-interface LoopBack0
 peer 2002:2201:102:A::1 as-number 64513 
 peer 2002:2201:102:A::1 ebgp-max-hop 2 
 peer 2002:2201:102:A::1 connect-interface LoopBack0
 #
 ipv4-family unicast
  undo synchronization
 #
 ipv6-family unicast
  undo synchronization
  peer 2002:2201:102:6::1 enable
  peer 2002:2201:102:A::1 enable
#
user-interface con 0
 authentication-mode password
user-interface vty 0 4
user-interface vty 16 20
#
wlan ac
#
return

R8

<Huawei>dis cu
[V200R003C00]
#
 snmp-agent local-engineid 800007DB03000000000000
 snmp-agent 
#
 clock timezone China-Standard-Time minus 08:00:00
#
portal local-server load portalpage.zip
#
 drop illegal-mac alarm
#
ipv6 
#
 set cpu-usage threshold 80 restore 75
#
aaa 
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default 
 domain default_admin 
 local-user admin password cipher %$%$K8m.Nt84DZ}e#<0`8bmE3Uw}%$%$
 local-user admin service-type http
#
ospfv3 1
 router-id 8.8.8.8
#
firewall zone Local
 priority 15
#
interface GigabitEthernet0/0/0
 ipv6 enable 
 ipv6 address 2002:2201:102:8::2/64 
 ospfv3 1 area 0.0.0.0
#
interface GigabitEthernet0/0/1
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
interface LoopBack0
 ipv6 enable 
 ipv6 address 2002:2201:102:A::1/64 
 ospfv3 1 area 0.0.0.0
#
bgp 64513
 router-id 8.8.8.8
 confederation id 2
 confederation peer-as 64512
 peer 2002:2201:102:9::1 as-number 64512 
 peer 2002:2201:102:9::1 ebgp-max-hop 2 
 peer 2002:2201:102:9::1 connect-interface LoopBack0
 #
 ipv4-family unicast
  undo synchronization
 #
 ipv6-family unicast
  undo synchronization
  peer 2002:2201:102:9::1 enable
#
user-interface con 0
 authentication-mode password
user-interface vty 0 4
user-interface vty 16 20
#
wlan ac
#
return
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值