1008 Elevator (20 分)-PAT甲级

The highest building in our city has only one elevator(电梯). A request list(请求列表) is made up(由……组成) with N positive numbers. The numbers denote at(表示) which floors the elevator will stop, in specified order(特定的顺序). It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill(履行,执行) the requests(请求) on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor(一楼) when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line(在一条线上).

Sample Input:

3 2 3 1

Sample Output:

41

 思路:1.边输入边计算的思想

            2.总耗时=(请求次数)*5+(电梯上升层数)*6+(电梯下降层数)*4

            3.将数组a[i]元素与其前一项相减,差值为正即为上升,差值为负即为下降,temp 存的正是数组元素前一项    

             4.其实数组非必需的。

 AC代码

#include <iostream>
#include <vector>
using namespace std;
int main()
{
	int n;
	cin>>n;
	vector<int> a(n);
	int temp=0;
	int sum=0;
	sum+=n*5; 
	for(int i=0;i<n;i++)
	{
		cin>>a[i];
		if(a[i]-temp>0)
			sum+=(a[i]-temp)*6;
		else
			sum+=(temp-a[i])*4;
		temp=a[i];
	}
	cout<<sum;
	return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值