1050 String Subtraction (20 分)-PAT甲级

Given two strings S1​ and S2​, S=S1​−S2​ is defined to be the remaining string after taking all the characters in S2​ from S1​. Your task is simply to calculate S1​−S2​ for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S1​ and S2​, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S1​−S2​ in one line.

Sample Input:

They are students.
aeiou

Sample Output:

Thy r stdnts.

 思路:1.用map<char,bool>标记s2出现过的字符,通过遍历s1删除被标记的字符

            2.map<char,bool>的value默认为false

            3.删除字符串s指定位置i的n个字符指令为s.erase(i,n);

AC代码 

#include <iostream>
#include <string> 
#include <map>
using namespace std;
int main()
{
	string s,ss;
	getline(cin,s);
	getline(cin,ss);
	map<char,bool>m;
	for(int i=0;i<ss.size();i++)
		m[ss[i]]=true;
	for(int i=0;i<s.size();i++)
	{
		if(m[s[i]])
		{
			s.erase(i,1);
			i--;
		}
	}
	cout<<s;
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值