1037 Magic Coupon (25 分)-PAT甲级

The magic shop in Mars is offering some magic coupons(优惠券). Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back(你可以拿回该产品价值的N倍)! What is more(而且), the shop also offers some bonus(奖金) product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product(你必须向这个商店支付奖金产品价值的N倍)... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once(最多被选择一次). Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons NC​, followed by a line with NC​ coupon integers. Then the next line contains the number of products NP​, followed by a line with NP​ product values. Here 1≤NC​,NP​≤105, and it is guaranteed that all the numbers will not exceed 230.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

4
1 2 4 -1
4
7 6 -2 -3

Sample Output:

43

 题目大意:给定N个coupon的数额和M个product的数额,要求输出返还的money最大值

 思路:题目的本质是在求coupon和product之间乘积和的最大值,乘积为正即累加,为负就舍弃,同时为了得到最大值,两个正数相乘的情况两个正数越大越好,两个负数相乘的情况两个负数越小越好,所以要现将coupon和money递减排序再进行计算,最后得出的和就是所求值

 AC代码

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
int main()
{
	long long sum=0;
	int m,n,i,j;
	cin>>n;
	vector<int> coupon(n);
	for(i=0;i<n;i++)
		cin>>coupon[i];
	cin>>m;
	vector<int> product(m);
	for(i=0;i<m;i++)
		cin>>product[i];
	sort(coupon.begin(),coupon.end(),greater<int>());
	sort(product.begin(),product.end(),greater<int>());
	for(i=0,j=0;coupon[i]*product[j]>0&&i<n&&j<m;i++,j++)
		sum+=coupon[i]*product[j];
	if(!(i==n||j==m))
		for(i=0,j=0;coupon[coupon.size()-i-1]*product[product.size()-j-1]>0&&i<n&&j<m;i++,j++)
			sum+=coupon[coupon.size()-i-1]*product[product.size()-j-1];
	cout<<sum;
	return 0;
}

更多PAT甲级题目:请访问PAT甲级刷题之路--题目索引+知识点分析(正在进行),感谢支持!

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值