1022 Digital Library (30 分)-PAT甲级

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID's.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤104) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

  • Line #1: the 7-digit ID number;
  • Line #2: the book title -- a string of no more than 80 characters;
  • Line #3: the author -- a string of no more than 80 characters;
  • Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
  • Line #5: the publisher -- a string of no more than 80 characters;
  • Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].

It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (≤1000) which is the number of user's search queries. Then M lines follow, each in one of the formats shown below:

  • 1: a book title
  • 2: name of an author
  • 3: a key word
  • 4: name of a publisher
  • 5: a 4-digit number representing the year

Output Specification:

For each query, first print the original query in a line, then output the resulting book ID's in increasing order, each occupying a line. If no book is found, print Not Found instead.

Sample Input:

3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla

Sample Output:

1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found

题目大意:给定书籍的一些相关信息,要求根据这些信息查找给定书籍的编号 ,没有找到就输出“Not Found”。

思路:1.典型的map+set容器问题 ,map实现映射关键字对应的编号,set对存储在map中的对应编号进行排序

2.难点在于换行符的读取上,cin输入完毕后按回车会在缓冲区留下换行符,需要用cin.ignore()函数吞掉。

3.注意key words有多个,以空格分隔,当做map下标时要分离key words。

AC代码 

#include <iostream>
#include <map> 
#include <set>
using namespace std;
int main()
{
	int n;
	string s,ss;
	map<string,set<string>>m[6];
	cin>>n;
	cin.ignore();
	for(int i=0;i<n;i++)
	{
		cin>>s;
		cin.ignore();
		for(int j=1;j<=5;j++)
		{
			getline(cin,ss);
			if(j==3)
			{
				int temp1=0;
				for(int k=0;k<=ss.size();k++)
				{
					if(ss[k]==' '||k==ss.size())
					{
						m[j][ss.substr(temp1,k-temp1)].insert(s);
						temp1=k+1;
					}
				}
			}
			else m[j][ss].insert(s);	
		}	
	} 
	int cnt;
	string temp;
	cin>>cnt;
	cin.ignore();
	set<string>::iterator it;
	for(int i=0;i<cnt;i++)
	{
		getline(cin,temp);
		cout<<temp<<endl;
		if(m[(temp[0]-'0')][temp.substr(3,temp.length()-3)].empty())
			cout<<"Not Found"<<endl;
		else
		{
			for(it=m[(temp[0]-'0')][temp.substr(3,temp.length()-3)].begin();it!=m[(temp[0]-'0')][temp.substr(3,temp.length()-3)].end();it++)
				cout<<*it<<endl;
		}
	}
	return 0;
}

更多PAT甲级题目:请访问PAT甲级刷题之路--题目索引+知识点分析(正在进行),感谢支持!

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值