1046 Shortest Distance (20 分)-PAT甲级

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3,105]), followed by N integer distances D1​ D2​ ⋯ DN​, where Di​ is the distance between the i-th and the (i+1)-st exits, and DN​ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7

 题目大意:求一环形高速公路给定顶点间的最短距离。

 思路:1.这题的本质还是求给定区间的元素和,而且是一次输入,多次查询的类型,可以想到数组前缀和,与普通直线数组不同,这个数组可以理解为环形数组,即数组总长一定,两个顶点之间的路线有两条,即为以两顶点为分隔的外围曲线,设这两条路径曲线的长度分别为

s1,s2,这个环的总长为s,则有s1+s2=s,由此性质可知,如果其中一条小于或等于s/2,那这条就是这两个顶点间的最短距离,如果其中一条大于s/2,那么另一条就是就是这两个顶点间的最短距离。 

2.采用sum数组来保存前缀和,置sum[0]=0,sum[i]表示为顺时针方向第1个顶点到第i+1个顶点的距离,那么m,n之间的距离(m<n)可表示为sum[n-1]-sum[m-1]

 AC代码

#include <iostream> 
using namespace std;
int sum[1000001] = {0};
int main() {
	int n;  
	scanf("%d", &n);
	for (int i = 1; i <= n; i++) {
		int temp;
		scanf("%d", &temp);
		sum[i] = sum[i - 1] + temp;
	}
	int m;
	scanf("%d", &m);
	while (m--) {
		int start, end;
		scanf("%d%d", &start, &end);
		if (start > end) {
			swap(start, end);
		}
		if (sum[end - 1] - sum[start - 1] <= sum[n] / 2) {
			printf("%d\n", sum[end - 1] - sum[start - 1]);
		} else {
			printf("%d\n", sum[n] - sum[end - 1] + sum[start - 1]); 
		}
	}
	return 0;
}

  更多PAT甲级题目:请访问PAT甲级刷题之路--题目索引+知识点分析(正在进行),感谢支持!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
GCN (Graph Convolutional Network) Shortest-Path-Master 是一种基于图卷积网络的最短路径算法。最短路径问题是图论中的经典问题,对于给定的图和起始点,找到到达目标点的最短路径。 GCN Shortest-Path-Master 通过应用图卷积神经网络的思想来解决最短路径问题。传统的最短路径算法(如Dijkstra算法或贝尔曼-福特算法)在计算过程中不考虑节点的特征信息,只利用图的拓扑结构。而GCN Shortest-Path-Master 利用了节点的特征信息,将节点的邻居节点信息通过图卷积操作进行聚合,得到节点的新特征表示。 GCN Shortest-Path-Master 的核心思想是,通过图卷积层不断更新节点的特征表示,使得节点的特征表示能够包含更多关于最短路径的信息。在每次迭代中,GCN Shortest-Path-Master 将节点的特征与邻居节点的特征进行聚合,得到节点的新特征表示。在网络的最后一层,通过对所有节点进行类任务,可以得到每个节点到达目标点的最短路径预测。 相比传统的最短路径算法,GCN Shortest-Path-Master 提供了以下优势: 1. GCN Shortest-Path-Master 能够利用节点的特征,从而更好地表达节点之间的相互作用和联系。 2. GCN Shortest-Path-Master 可以自适应地学习节点的特征表示,而无需人工定义特征。 3. GCN Shortest-Path-Master 可以处理大规模的图结构,在计算效率上具有一定优势。 总之,GCN Shortest-Path-Master 是一种基于图卷积神经网络的最短路径算法,通过利用节点的特征信息,能够更好地解决最短路径问题。它在图结构数据中的应用具有很大潜力,在社交网络析、推荐系统和物流路径规划等领域都有广泛的应用前景。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值