7-23 文件传输

当两台计算机双向连通的时候,文件是可以在两台机器间传输的。给定一套计算机网络,请你判断任意两台指定的计算机之间能否传输文件?

输入格式:

首先在第一行给出网络中计算机的总数 N (2≤N≤104),于是我们假设这些计算机从 1 到 N 编号。随后每行输入按以下格式给出:

I c1 c2  

其中I表示在计算机c1c2之间加入连线,使它们连通;或者是

C c1 c2    

其中C表示查询计算机c1c2之间能否传输文件;又或者是

S

这里S表示输入终止。

输出格式:

对每个C开头的查询,如果c1c2之间可以传输文件,就在一行中输出"yes",否则输出"no"。当读到终止符时,在一行中输出"The network is connected."如果网络中所有计算机之间都能传输文件;或者输出"There are k components.",其中k是网络中连通集的个数。

输入样例 1:

5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
S

输出样例 1:

no
no
yes
There are 2 components.

输入样例 2:

5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
I 1 3
C 1 5
S

输出样例 2:

no
no
yes
yes
The network is connected.

代码如下: 

#include<bits/stdc++.h>
using namespace std;
int n;
int fa[10005];

void init(int n){
	for(int i = 0;i<n;i++){
		fa[i] = i;
	}
}
int find(int x){
	if(fa[x]==x)
	return x;
	else{
		fa[x] = find(fa[x]);
		return fa[x];
	}
}
void merge(int x,int y){
	int a = find(x);
	int b = find(y);
	if(a!=b){
		fa[a] = b;
	}
}
int main(){
	int n,x,y;
	cin>>n;
	init(n);
	char ch;
	while(cin>>ch&&ch!='S'){
		cin>>x>>y;
		if(ch=='I'){
			merge(x,y);
		}else{
			if(find(x)==find(y)){
				cout<<"yes"<<endl;
			}else{
				cout<<"no"<<endl;
			}
		}
	}
	int cnt = 0;
	for(int i = 0;i<n;i++){
		if(fa[i]==i)
		cnt++;
	}
	if(cnt==1){
		cout<<"The network is connected."<<endl;
	}else{
		cout<<"There are "<<cnt<<" components."<<endl;
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值