Acwing1135.新年好

该问题是一个图论问题,通过Dijkstra算法求解每个车站到其他车站的最短路径,并使用DFS遍历所有可能的拜访顺序,找出总时间最少的方案。给定车站数量、公路数量以及亲戚位置,输入还包括公路连接信息,输出是最短的总时间。程序中定义了图的邻接表结构,并使用优先队列优化Dijkstra算法。
摘要由CSDN通过智能技术生成

重庆城里有 n n n 个车站, m m m双向 公路连接其中的某些车站。

每两个车站最多用一条公路连接,从任何一个车站出发都可以经过一条或者多条公路到达其他车站,但不同的路径需要花费的时间可能不同。

在一条路径上花费的时间等于路径上所有公路需要的时间之和。

佳佳的家在车站 1 1 1,他有五个亲戚,分别住在车站 a , b , c , d , e a,b,c,d,e a,b,c,d,e

过年了,他需要从自己的家出发,拜访每个亲戚(顺序任意),给他们送去节日的祝福。

怎样走,才需要最少的时间?

输入格式

第一行:包含两个整数 n , m n,m n,m,分别表示车站数目和公路数目。

第二行:包含五个整数 a , b , c , d , e a,b,c,d,e a,b,c,d,e,分别表示五个亲戚所在车站编号。

以下 m m m 行,每行三个整数 x , y , t x,y,t x,y,t,表示公路连接的两个车站编号和时间。

输出格式

输出仅一行,包含一个整数 T T T,表示最少的总时间。

数据范围

1 ≤ n ≤ 50000 , 1 ≤ m ≤ 105 , 1 < a , b , c , d , e ≤ n , 1 ≤ x , y ≤ n , 1 ≤ t ≤ 100 1≤n≤50000, 1≤m≤105, 1<a,b,c,d,e≤n, 1≤x,y≤n, 1≤t≤100 1n50000,1m105,1<a,b,c,d,en,1x,yn,1t100

输入样例:

6 6
2 3 4 5 6
1 2 8
2 3 3
3 4 4
4 5 5
5 6 2
1 6 7

输出样例:

21

图论加dfs,对于每个车站都做一遍dijkstra,爆搜一遍所有情况即可,sizeof无法确定数组为参数大小,所以需要memet中的大小为N * 4

#include <iostream>
#include <algorithm>
#include <cstring>
#include <queue>
#define x first
#define y second

using namespace std;

const int N = 50010, M = 2e5 + 10;
typedef pair<int, int> PII;

int star[6];
int n, m;//车站和公路数目
int h[N], e[M], ne[M], w[M], idx;
int dist[6][N];
bool st[N];
int res = 2e9;

void add(int a, int b, int c)
{
    e[idx] = b, w[idx] = c, ne[idx] = h[a], h[a] = idx ++;
}

void dfs(int u, int start,int distance)
{
    if(distance >= res) return;
    if(u >= 5) res = min(res, distance);

    for(int i = 1; i <= 5; i ++)
    {
        int next = star[i];
        if(!st[i])
        {
            st[i] = true;
            dfs(u + 1, i, distance + dist[start][next]);
            st[i] = false;
        }
    }
}

void dijkstra(int start, int dist[])
{
    priority_queue<PII, vector<PII>, greater<PII> > heap;

    memset(dist, 0x3f, N * 4);
    memset(st, 0, sizeof st);

    dist[start] = 0;
    heap.push({0, start});

    while(heap.size())
    {
        int t = heap.top().y;
        heap.pop();

        if(st[t]) continue;
        st[t] = true;

        for(int i = h[t]; i != -1; i = ne[i])
        {
            int j = e[i];
            if(dist[j] > dist[t] + w[i])
            {
                dist[j] = dist[t] + w[i];
                heap.push({dist[j], j});
            }
        }
    }   
}

int main()
{
    scanf("%d%d", &n, &m);
    memset(h, -1, sizeof h);
    star[0] = 1;
    for(int i = 1; i <= 5; i ++) scanf("%d", &star[i]);

    while(m --)
    {
        int x, y, t;
        scanf("%d%d%d", &x, &y, &t);
        add(x, y, t), add(y, x, t);
    }

    for(int i = 0; i <= 5; i ++) dijkstra(star[i], dist[i]);

    memset(st, 0, sizeof st);

    dfs(0, 0, 0);

    cout << res << endl;

    return 0;   
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

王奇hh

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值