PTA 抢红包 25分 (JAVA)

题目描述

没有人没抢过红包吧…… 这里给出N个人之间互相发红包、抢红包的记录,请你统计一下他们抢红包的收获。

输入格式:

输出格式:

按照收入金额从高到低的递减顺序输出每个人的编号和收入金额(以元为单位,输出小数点后2位)。每个人的信息占一行,两数字间有1个空格。如果收入金额有并列,则按抢到红包的个数递减输出;如果还有并列,则按个人编号递增输出。

输入样例:

10
3 2 22 10 58 8 125
5 1 345 3 211 5 233 7 13 8 101
1 7 8800
2 1 1000 2 1000
2 4 250 10 320
6 5 11 9 22 8 33 7 44 10 55 4 2
1 3 8800
2 1 23 2 123
1 8 250
4 2 121 4 516 7 112 9 10

输出样例:

1 11.63
2 3.63
8 3.63
3 2.11
7 1.69
6 -1.67
9 -2.18
10 -3.26
5 -3.26
4 -12.32

题解:

只能19分了,有一个超时,不知道再怎么优化

import java.util.Arrays;
import java.util.Scanner;

class Person {
    int num; //编号
    double money;
    int count; //抢到红包的个数
}

public class Main {
    public static void main(String[] args) {
        Scanner scanner = new Scanner(System.in);
        int N = scanner.nextInt();
        Person[] people = new Person[N];

        for (int i = 0; i < N; i++) { //初始化结构体数组
            people[i] = new Person();
            people[i].num = i + 1;
            people[i].count = 0;
            people[i].money = 0;
        }

        for (int i = 0; i < N; i++) { //输入发红包,抢红包数据
            int n = scanner.nextInt();
            for (int j = 0; j < n; j++) {
                int m = scanner.nextInt();
                int money = scanner.nextInt();
                people[i].money -= money;
                people[m - 1].money += money;
                people[m - 1].count++;
            }
        }

        Arrays.sort(people, (p1, p2) -> { //排序
            if (p1.money == p2.money) {
                if (p1.count == p2.count) {
                    return p1.num - p2.num;
                }
                return p2.count - p1.count;
            }
            return Double.compare(p2.money, p1.money);
        });

        for (int i = 0; i < N; i++) { //输出
            System.out.print(people[i].num + " ");
            System.out.printf("%.2f\n", people[i].money / 100);
        }
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

.lby.

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值