目录
题目描述
输出7和7的倍数,还有包含7的数字例如(17,27,37...70,71,72,73...)
输入
首先输入一个整数t,表示有t组数据。
然后有t行,每行一个整数N。(N不大于30000)
输出
对于每组数据 ,输出从小到大排列的不大于N的与7有关的数字。每组数据占一行,每个数字后面有一个空格;
样例输入 Copy
2 20 30
样例输出 Copy
7 14 17 7 14 17 21 27 28
code
import java.util.*;
public class Main {
public static boolean che(int x) {
if (x % 7 == 0) return true;
while (x > 0) {
int a = x % 10;
if (a == 7) return true;
x /= 10;
}
return false;
}
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
int T = sc.nextInt();
while (T -- > 0) {
int n = sc.nextInt();
for (int i = 7; i <= n; i ++) {
if (che(i))
System.out.print(i+" ");
}
System.out.println();
}
}
}