最大子列和问题Maximum Subsequence Sum (25 分)

开启数据结构的学习啦!
浙大版《数据结构(第2版)》题目集
实例1.1 最大子列和问题 (20 分)
给定K个整数组成的序列{ N1,N2, …, NK},“连续子列”被定义为{ Ni,Ni+1, …, Nj},其中 1≤i≤j≤K。“最大子列和”则被定义为所有连续子列元素的和中最大者。例如给定序列{ -2, 11, -4, 13, -5, -2 },其连续子列{ 11, -4, 13 }有最大的和20。现要求你编写程序,计算给定整数序列的最大子列和。

本题旨在测试各种不同的算法在各种数据情况下的表现。各组测试数据特点如下:

数据1:与样例等价,测试基本正确性;
数据2:102个随机整数;
数据3:103个随机整数;
数据4:104个随机整数;
数据5:105个随机整数;
输入格式:
输入第1行给出正整数K (≤100000);第2行给出K个整数,其间以空格分隔。

输出格式:
在一行中输出最大子列和。如果序列中所有整数皆为负数,则输出0。

输入样例:
6
-2 11 -4 13 -5 -2
输出样例:
20

#include<stdio.h>
int main()
{
	int k,n,num=0,i,max=0;
	scanf("%d",&k);
	for(i=0;i<k;i++){
		scanf("%d",&n);
		num += n;
		if(num<0) num=0;
		else{
			if(max<num) max=num;
		} 
	}
	printf("%d",max);
	return 0;
 } 

在这里插入图片描述

Data Structures and Algorithms (English)
7-1 Maximum Subsequence Sum (25 分)
Given a sequence of K integers { N1,N2,…, NK}. A continuous subsequence is defined to be { Ni,Ni+1, …, Nj} where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:
Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:
For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4

#include<stdio.h>
int main()
{
	int k,num=0,i,max=0,max1=0,a[10000];
	int begin1,end1,begin,end,flag=0,fumax=-9999;
	scanf("%d",&k);
	for(i=0;i<k;i++)
	    scanf("%d",&a[i]);
	for(i=0;i<k;i++){
		if(a[i]>=0){
			flag=1;
			break;
		}
	}
	if(flag){
		for(i=0;i<k;i++){		
		num += a[i];
		if(num<=0) {
		    num=0; 
		    if(i+1<k){
		    	if(a[i+1]>0){
		    		begin1=a[i+1];
				    end1=a[i+1];
		    	}   
			}
		}
		else{
			if(num-a[i]<=0) begin1=a[i];
			if(max1<num) {
			    max1=num;
			    end1=a[i];
			}
		} 
	    if(num==0&&max1==0||max<max1){
			begin=begin1;
			end=end1;
		    max=max1;
	        }  
	    }
	    if(k==1){
			begin=a[0];
			end=a[0];
		}
		if(i==k&&max==0){
			begin=0;
			end=0;
		}
	    printf("%d %d %d",max,begin,end);
	}
	else{
		fumax=0;
		begin=a[0];
		end=a[k-1];					
		printf("%d %d %d",fumax,begin,end);
	}
	return 0;
 } 

英文版的可以免费提交,但是不太会改。不知道代码哪里错了,求助救救
在这里插入图片描述
下面是我自己测试的最大和前有一段0,不知道有什么问题:
在这里插入图片描述
等待大佬帮助

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

菜·肉多多·狗

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值