OSPF、MGRE综合实验

一、实验要求

1.R6为ISP只配置IP地址R1-R5的环回地址为私网网段
2.R1/R4/R5为全连的MGRM结构,R1/R2/R3为星型的拓扑结构,R1为中心站点
3.所有的私网网段可以互相通信,私网使用OSPF完成。

二、实验拓扑

三、实验分析

1.给各设备划分网段。(具体网段见拓扑图)

2.R1/R4/R5为全连的MGRE结构,需要各自以本生为中心战点,互相注册。

3.R1/R2/R3构建MGRE结构,R1为中心站点。

4.配置默认静态路由、OSPF, 修改MGRE下OSPF接口的网络类型。

四、实验配置

R1:

配置IP地址

#
interface GigabitEthernet0/0/0
 ip address 16.0.0.1 255.255.255.0 
#
interface GigabitEthernet0/0/1
 ip address 61.0.0.1 255.255.255.0 
#
interface LoopBack0
 ip address 192.168.1.1 255.255.255.0 
#

配置MGRE

#
interface Tunnel0/0/0
 ip address 192.168.6.1 255.255.255.0 
 tunnel-protocol gre p2mp
 source 61.0.0.1
 ospf network-type p2mp
 nhrp entry multicast dynamic
 nhrp network-id 100
 nhrp entry 192.168.6.4 46.0.0.4 register
 nhrp entry 192.168.6.5 56.0.0.5 register
#
interface Tunnel0/0/1
 ip address 192.168.7.1 255.255.255.0 
 tunnel-protocol gre p2mp
 source 16.0.0.1
 ospf network-type p2mp
 nhrp entry multicast dynamic
 nhrp network-id 200
#

配置OSPF和默认路由

#
ospf 100 
 area 0.0.0.0 
  network 192.168.1.0 0.0.0.255 
  network 192.168.6.0 0.0.0.255 
  network 192.168.7.0 0.0.0.255 
#
ip route-static 0.0.0.0 0.0.0.0 61.0.0.6
ip route-static 0.0.0.0 0.0.0.0 16.0.0.6
#

R2:

配置IP地址

#
interface GigabitEthernet0/0/0
 ip address 26.0.0.2 255.255.255.0 
#
interface LoopBack1
 ip address 192.168.2.1 255.255.255.0 
#

配置MGRE

#interface Tunnel0/0/0
 ip address 192.168.7.2 255.255.255.0 
 tunnel-protocol gre p2mp
 source GigabitEthernet0/0/0
 ospf network-type p2mp
 nhrp entry multicast dynamic
 nhrp network-id 200
 nhrp entry 192.168.7.1 16.0.0.1 register

#

配置OSPF和默认路由

#
ospf 100 
 area 0.0.0.0 
  network 192.168.2.0 0.0.0.255 
  network 192.168.7.0 0.0.0.255 
#
ip route-static 0.0.0.0 0.0.0.0 26.0.0.6
#

R3:

配置IP地址

#
interface GigabitEthernet0/0/0
 ip address 36.0.0.3 255.255.255.0 
#
interface LoopBack1
 ip address 192.168.3.1 255.255.255.0 
#

配置MGRE

#
interface Tunnel0/0/0
 ip address 192.168.7.4 255.255.255.0 
 tunnel-protocol gre p2mp
 source GigabitEthernet0/0/0
 ospf network-type p2mp
 nhrp entry multicast dynamic
 nhrp network-id 200
 nhrp entry 192.168.7.1 16.0.0.1 register
#

配置OSPF和默认路由

#
ospf 100 router-id 3.3.3.3 
 area 0.0.0.0 
  network 192.168.3.0 0.0.0.255 
  network 192.168.7.0 0.0.0.255 
#
ip route-static 0.0.0.0 0.0.0.0 36.0.0.6
#
R4:

配置IP地址

#
interface GigabitEthernet0/0/0
 ip address 46.0.0.4 255.255.255.0 
#
interface LoopBack1
 ip address 192.168.4.1 255.255.255.0 
#
 

配置MGRE

#
interface Tunnel0/0/0
 ip address 192.168.6.4 255.255.255.0 
 tunnel-protocol gre p2mp
 source 46.0.0.4
 ospf network-type p2mp
 nhrp entry multicast dynamic
 nhrp network-id 100
 nhrp entry 192.168.6.1 61.0.0.1 register
 nhrp entry 192.168.6.5 56.0.0.5 register
#
 

配置OSPF和默认路由

#
ospf 100 
 area 0.0.0.0 
  network 192.168.4.0 0.0.0.255 
  network 192.168.6.0 0.0.0.255 
#
ip route-static 0.0.0.0 0.0.0.0 46.0.0.6
#
 

R5:

配置IP地址

#
interface GigabitEthernet0/0/0
 ip address 56.0.0.5 255.255.255.0 
#
interface LoopBack1
 ip address 192.168.5.1 255.255.255.0 
#

配置MGRE

#
interface Tunnel0/0/0
 ip address 192.168.6.5 255.255.255.0 
 tunnel-protocol gre p2mp
 source 56.0.0.5
 ospf network-type p2mp
 nhrp entry multicast dynamic
 nhrp network-id 100
 nhrp entry 192.168.6.4 46.0.0.4 register
#
 

配置OSPF和默认路由

#
ospf 100 
 area 0.0.0.0 
  network 192.168.5.0 0.0.0.255 
  network 192.168.6.0 0.0.0.255 
#
ip route-static 0.0.0.0 0.0.0.0 56.0.0.6
#

ISP

配置IP地址

#
interface GigabitEthernet0/0/0
 ip address 16.0.0.6 255.255.255.0 
#
interface GigabitEthernet0/0/1
 ip address 61.0.0.6 255.255.255.0 
#
interface GigabitEthernet0/0/2
 ip address 56.0.0.6 255.255.255.0 
#
interface GigabitEthernet2/0/0
 ip address 26.0.0.6 255.255.255.0 
#
interface GigabitEthernet3/0/0
 ip address 36.0.0.6 255.255.255.0 
#
interface GigabitEthernet4/0/0
 ip address 46.0.0.6 255.255.255.0 
#
五、验证

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值