小单刷题笔记之类和对象基础

题一:学生信息处理程序

描述

实现一个学生信息处理程序,计算一个学生的四年平均成绩。

要求实现一个代表学生的类,并且类中所有成员变量都是【私有的】。

补充下列程序中的 Student 类以实现上述功能。

#include <iostream>
#include <string>
#include <cstdio>
#include <cstring>
#include <sstream>
#include <cstdlib>
using namespace std;

class Student {
// 在此处补充你的代码
};

int main() {
	Student student;        // 定义类的对象
	student.input();        // 输入数据
	student.calculate();    // 计算平均成绩
	student.output();       // 输出数据
}

输入

输入数据为一行,包括:
姓名,年龄,学号,第一学年平均成绩,第二学年平均成绩,第三学年平均成绩,第四学年平均成绩。
其中姓名为由字母和空格组成的字符串(输入保证姓名不超过20个字符,并且空格不会出现在字符串两端),年龄、学号和学年平均成绩均为非负整数。信息之间用逗号隔开。

输出

输出一行数据,包括:
姓名,年龄,学号,四年平均成绩。
信息之间用逗号隔开。

样例输入

Tom Hanks,18,7817,80,80,90,70

样例输出

Tom Hanks,18,7817,80
#include <iostream>
#include <string>
#include <cstdio>
#include <cstring>
#include <sstream>
#include <cstdlib>
using namespace std;

class Student {
// 在此处补充你的代码
	private:
		char name[22] ;
		char c;
		int age;
		int num;
		int ave[4];
		double outave;
	public:
		void input(){
		cin.getline(name,22,',');//第三个参数终止
		cin>>age>>c>>num>>c;
		cin>>ave[0]>>c>>ave[1]>>c;
		cin>>ave[2]>>c>>ave[3];
		}
		
		void calculate(){
			outave=(double)(ave[0]+ave[1]+ave[2]+ave[3])/4.00;
		}
		
		void output(){
			
			for(int i=0;name[i];i++){
				cout<<name[i];
				
			}
			cout<<c<<age<<c<<num<<c<<outave;
			
		}
};

int main() {
	Student student;        // 定义类的对象
	student.input();        // 输入数据
	student.calculate();    // 计算平均成绩
	student.output();       // 输出数据
	
	
}

题二:奇怪的类复制

输入

输出

9
22
5

样例输入

None

样例输出

9
22
5
#include <iostream>
using namespace std;
class Sample {
public:
	int v;
// 在此处补充你的代码
	 Sample(const Sample &c){//注意加const关键字
		if(c.v==5){
		v=c.v+2;}
		else v=c.v+2;
	}
	 Sample(int a){
		v=a;
	}
	Sample(){};
};
void PrintAndDouble(Sample o)//参数会生成临时对象 又会调用复制构造函数 
{
	cout << o.v;
	cout << endl;
}
int main()
{
	Sample a(5);
	Sample b = a;//初始化 用复制构造函数+2 
	PrintAndDouble(b);//生成临时对象又+2 
	Sample c = 20;//类型转换构造函数 c.v=20; 
	PrintAndDouble(c);// 生成临时对象 +2; 
	Sample d;
	d = a;
	cout << d.v;
	return 0;
}

题三:超简单的复制类

  输出:3+4i

             5+6i

#include <iostream>
#include <cstring>
#include <cstdlib>
using namespace std;
class Complex {
private:
    double r,i;
public:
    void Print() {
        cout << r << "+" << i << "i" << endl;
    }
// 在此处补充你的代码
	Complex(){}
	Complex(const char a[4]){
		r=a[0]-'0';
		i=a[2]-'0';
	}
};
int main() {
    Complex a;
    a = "3+4i"; a.Print();
    a = "5+6i"; a.Print();
    return 0;
}

题四:哪来的输出

   输出:2,1

#include <iostream>
using namespace std;
class A {
	public:
		int i;
		A(int x) { i = x; }
// 在此处补充你的代码
		~A(){
			cout<<i<<endl;
		}
};
int main()
{
	A a(1);
	A * pa = new A(2);
	delete pa;//调用一次析构函数
                
	return 0;
}//调用a的析构函数

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值