1064 Complete Binary Search Tree(19行代码+详细注释)

分数 30

全屏浏览题目

作者 CHEN, Yue

单位 浙江大学

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

#include<bits/stdc++.h>
using namespace std;
const int N=1005;
int n,a[N],res[N];//分别保存输入和输出的序列 
void inorder(int u,int &cur){
    if(2*u<=n)inorder(2*u,cur);//若有左子树则递归遍历左子树 
    res[u]=a[cur++];//找到左子树的第一个结点并保存中序序列的当前值,之后再指向当前元素的下一个元素 
    if(2*u+1<=n)inorder(2*u+1,cur);//若有右子树则递归遍历右子树 
}
int main(){
    cin>>n;
    for(int i=0;i<n;i++)cin>>a[i];//输入 
    sort(a,a+n);//从小到大排序,即为二叉搜索树的中序遍历 
    int cur=0;//用于保存结果序列,从0到n-1 
    inorder(1,cur);//中序遍历完全二叉树,并按照中序序列插入元素,最后所得就是完全二叉搜索树 
    cout<<res[1]; //单独输出第一个元素 
    for(int i=2;i<=n;i++)cout<<' '<<res[i];//从第二开始输出空格+元素 
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值