1129 Recommendation System(26行代码+超详细注释)

分数 25

全屏浏览题目

切换布局

作者 CHEN, Yue

单位 浙江大学

Recommendation system predicts the preference that a user would give to an item. Now you are asked to program a very simple recommendation system that rates the user's preference by the number of times that an item has been accessed by this user.

Input Specification:

Each input file contains one test case. For each test case, the first line contains two positive integers: N (≤ 50,000), the total number of queries, and K (≤ 10), the maximum number of recommendations the system must show to the user. Then given in the second line are the indices of items that the user is accessing -- for the sake of simplicity, all the items are indexed from 1 to N. All the numbers in a line are separated by a space.

Output Specification:

For each case, process the queries one by one. Output the recommendations for each query in a line in the format:

query: rec[1] rec[2] ... rec[K]

where query is the item that the user is accessing, and rec[i] (i=1, ... K) is the i-th item that the system recommends to the user. The first K items that have been accessed most frequently are supposed to be recommended in non-increasing order of their frequencies. If there is a tie, the items will be ordered by their indices in increasing order.

Note: there is no output for the first item since it is impossible to give any recommendation at the time. It is guaranteed to have the output for at least one query.

Sample Input:

12 3
3 5 7 5 5 3 2 1 8 3 8 12

Sample Output:

5: 3
7: 3 5
5: 3 5 7
5: 5 3 7
3: 5 3 7
2: 5 3 7
1: 5 3 2
8: 5 3 1
3: 5 3 1
8: 3 5 1
12: 3 5 8

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

#include<bits/stdc++.h>
using namespace std;
const int N=50010;
int n,k,t,cnt[N],top_k[11],cur;
bool cmp(int a,int b){//按出现频率从大到小排序,相同则按商品编号从小到大排序 
    return cnt[a]!=cnt[b]?cnt[a]>cnt[b]:a<b;
}
int main(){
    cin>>n>>k;
    for(int i=0;i<n;i++){
        scanf("%d",&t);
        if(i>0){//从第二个开始输出 
            printf("%d:",t);//输出当前的编号 
            for(int j=0;j<cur;j++)printf(" %d",top_k[j]);//输出当前排名前cur个的商品 
            printf("\n");
        }
        cnt[t]++;//t商品出现频率+1 
        bool isexist=false;
        for(int j=0;j<k;j++)//遍历前k个推荐商品 
            if(top_k[j]==t)isexist=true;//若出现当前访问商品和之前访问相同置为true 
        if(!isexist)top_k[cur++]=t;//若当前访问商品不在之前访问的商品当中,插入到top_k中 
        sort(top_k,top_k+cur,cmp);//对前cur+1个商品排序 
        cur=min(cur,k);//cur最大值不超过k 
    }
    return 0;

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值