MPLS VPN

实验要求:

1. R1与R5MPLS VPN
2. R6与R7MPLS VPN
3. R7可以访问R2/3/4的环回


实验步骤以及结果: 

1、IP地址规划拓扑设计

2、在公网配置ospf

[r2]ospf 1 router-id 2.2.2.2
[r2-ospf-1]area 0  
[r2-ospf-1-area-0.0.0.0]network 23.1.1.1 0.0.0.0
[r2-ospf-1-area-0.0.0.0]network 2.2.2.2 0.0.0.0

[r3]ospf 1 router-id 3.3.3.3  
[r3-ospf-1]area 0 
[r3-ospf-1-area-0.0.0.0]network 23.1.1.2 0.0.0.0

[r3-ospf-1-area-0.0.0.0]network 3.3.3.3 0.0.0.0
[r3-ospf-1-area-0.0.0.0]network 34.1.1.1 0.0.0.0

[r4]ospf 1 router-id 4.4.4.4
[r4-ospf-1]area 0
[r4-ospf-1-area-0.0.0.0]network 34.1.1.2 0.0.0.0
[r4-ospf-1-area-0.0.0.0]network 4.4.4.4 0.0.0.0

[r4-ospf-1-area-0.0.0.0]network 47.1.1.1 0.0.0.0

[r4-ospf-1]silent-interface GigabitEthernet 0/0/1        #把R4的g0/0/1接口配置成环回接口
[r4]int g0/0/1  
[r4-GigabitEthernet0/0/1]ospf authentication-mode md5 1 cipher 123456        #g0/0/1接口做认证

[r7]ip route-static 0.0.0.0 0.0.0.0 47.1.1.1

3、在公网开启MPLS域

[r2]mpls lsr-id 2.2.2.2
[r2]mpls    
[r2-mpls]mpls ldp
[r2-mpls-ldp]int g0/0/2   
[r2-GigabitEthernet0/0/2]mpls   
[r2-GigabitEthernet0/0/2]mpls ldp 

[r3]mpls lsr-id 3.3.3.3
[r3]mpls
[r3-mpls] mpls ldp
[r3-mpls-ldp]int g0/0/0
[r3-GigabitEthernet0/0/0]mpls
[r3-GigabitEthernet0/0/0] mpls ldp
[r3-GigabitEthernet0/0/0]int g0/0/1
[r3-GigabitEthernet0/0/1]mpls
[r3-GigabitEthernet0/0/1] mpls ldp

[r4]mpls lsr-id 4.4.4.4
[r4]mpls
[r4-mpls] mpls ldp
[r4-mpls-ldp]int g0/0/0
[r4-GigabitEthernet0/0/0]mpls
[r4-GigabitEthernet0/0/0] mpls ldp

4、配置MPLS VPN

#创建vpn空间a1

[r2]ip vpn-instance a1 
[r2-vpn-instance-a1]ipv4-family    
[r2-vpn-instance-a1-af-ipv4]route-distinguisher 2:2 
[r2-vpn-instance-a1-af-ipv4]vpn-target 2:2

#进入g0/0/1绑定vpn空间a1并配置IP地址

[r2]int g0/0/1 
[r2-GigabitEthernet0/0/1]ip binding vpn-instance a1    
[r2-GigabitEthernet0/0/1]ip address 192.168.2.2 24

#创建vpn空间a2
[r4]ip vpn-instance a2  
[r4-vpn-instance-a2]ipv4-family    
[r4-vpn-instance-a2-af-ipv4]route-distinguisher 2:2
[r4-vpn-instance-a2-af-ipv4]vpn-target 2:2

#进入g4/0/0绑定vpn空间a2并配置IP地址

[r4-GigabitEthernet0/0/2]int g4/0/0
[r4-GigabitEthernet4/0/0]ip binding vpn-instance a2
[r4-GigabitEthernet4/0/0]ip address 192.168.3.1 24

#创建vpn空间b1

[r2]ip vpn-instance b1
[r2-vpn-instance-b1]ipv4    
[r2-vpn-instance-b1]ipv4-family 
[r2-vpn-instance-b1-af-ipv4]rou    
[r2-vpn-instance-b1-af-ipv4]route-distinguisher 1:1
[r2-vpn-instance-b1-af-ipv4]vpn    
[r2-vpn-instance-b1-af-ipv4]vpn-target 1:1

#进入g0/0/0绑定vpn空间b1并配置IP地址

[r2]int g0/0/0 
[r2-GigabitEthernet0/0/0]ip binding vpn-instance b1
[r2-GigabitEthernet0/0/0]ip address 192.168.2.2 24

#创建vpn空间b2

[r4]ip vpn-instance b2 
[r4-vpn-instance-b2]ipv4-family  
[r4-vpn-instance-b2-af-ipv4]route-distinguisher 1:1   
[r4-vpn-instance-b2-af-ipv4]vpn-target 1:1

#进入g0/0/2绑定vpn空间b2并配置IP地址

[r4]int g0/0/2
[r4-GigabitEthernet0/0/2]ip binding vpn-instance b2 
[r4-GigabitEthernet0/0/2]ip address 192.168.3.1 24

查看vpn a1的路由表: 

查看vpn b1的路由表: 

查看vpn a2和b2的路由表: 

5、配置BGP

[r2]bgp 1  
[r2-bgp]router-id 2.2.2.2 
[r2-bgp]peer 4.4.4.4 as-number 1
[r2-bgp]peer 4.4.4.4 connect-interface LoopBack 0  #建立普通的bgp邻居
[r2-bgp]ipv4-family vpnv4         #进入vpn建立vpn专用bgp
[r2-bgp-af-vpnv4]peer 4.4.4.4 enable 

[r4]bgp 1   
[r4-bgp]router-id 4.4.4.4  
[r4-bgp]peer 2.2.2.2 as-number 1  
[r4-bgp]peer 2.2.2.2 connect-interface LoopBack 0          #建立普通的bgp邻居
[r4-bgp]ipv4-family vpnv4        #进入vpn建立vpn专用bgp
[r4-bgp-af-vpnv4]peer 2.2.2.2 enable 

查看BGP邻居

6、R6与R7MPLS VPN

1)给R6配置IP地址并配置rip

[r6]int lo0
[r6-LoopBack0]ip address 192.168.1.1 24
[r6-LoopBack0]int g0/0/1
[r6-GigabitEthernet0/0/1]ip address 192.168.2.1 24
[r6]rip 1  
[r6-rip-1]version 2
[r6-rip-1]network 192.168.1.0
[r6-rip-1]network 192.168.2.0

[r2]rip 1 vpn-instance a1   #注意要在vpn空间a1配置rip
[r2-rip-1]ver 2  
[r2-rip-1]network 192.168.2.0

查看r2的vpn空间a1路由表



2)给R7配置IP地址并配置ospf

[r7]ospf 1 router-id 7.7.7.7
[r7-ospf-1]are    
[r7-ospf-1]area 0
[r7-ospf-1-area-0.0.0.0]net    
[r7-ospf-1-area-0.0.0.0]network 192.168.4.2 0.0.0.0
[r7-ospf-1-area-0.0.0.0]network 192.168.3.2 0.0.0.0

[r4]ospf 2 vpn-instance a2
[r4-ospf-2]are    
[r4-ospf-2]area 0
[r4-ospf-2-area-0.0.0.0]netw    
[r4-ospf-2-area-0.0.0.0]network 192.168.3.1 0.0.0.0

查看r4上的ospf邻居关系

3)重发布

[r2]bgp 1  
[r2-bgp]ipv4-family vpn-instance a1
[r2-bgp-a1]import-route rip 1

在r4上查看路由 

[r4]ospf 2 vpn-instance a2   
[r4-ospf-2]import-route bgp 

查看r7的vpn空间a2的路由表

[r4]bgp 1
[r4-bgp]ipv4-family vpn-instance a2  
[r4-bgp-a2]import-route ospf 2

查看r2上a1空间的bgp表

[r2]rip 1 vpn-instance a1  
[r2-rip-1]import-route bgp

查看r6的路由表 

 做到此处a1和a2就能相互访问。

 7、R1与R5MPLS VPN

1)给r1和r5配置IP地址,写静态路由

[r1]int lo0 
[r1-LoopBack0]ip address 192.168.1.1 24
[r1-LoopBack0]int g0/0/1 
[r1-GigabitEthernet0/0/1]ip address 192.168.2.1 24
[r1]ip route-static 192.168.3.0 24 192.168.2.2
[r1]ip route-static 192.168.4.0 24 192.168.2.2

[r2]ip route-static vpn-instance b1 192.168.1.0 24 192.168.2.1        #在vpn空间b1写一条静态路由

[r5]ip route-static 192.168.1.0 24 192.168.3.1
[r5]ip route-static 192.168.2.0 24 192.168.3.1

[r4]ip route-static vpn-instance b2 192.168.4.0 24 192.168.3.2         #在vpn空间b2写一条静态路由

2)重发布和宣告

#在r2的vpn空间b1中宣告

[r2]bgp 1
[r2-bgp]ipv4-family vpn-instance b1  
[r2-bgp-b1]network 192.168.1.0 24
[r2-bgp-b1]network 192.168.2.0 24

 查看r4的vpn空间b2的路由表

[r4]bgp 1
[r4-bgp]ipv4-family vpn-instance b2
[r4-bgp-b2]import-route direct         #重发布直连路由  
[r4-bgp-b2]import-route static         #重发布静态路由 

查看r2的vpn空间b1路由表

 测试:

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值