DAY 6 栈和队列

文章讲述了如何通过栈结构解决两个给定序列的验证问题以及一个关于小行星碰撞的LeetCode问题,涉及栈的操作和数组处理技巧。
摘要由CSDN通过智能技术生成

【深基15.习9】验证栈序列

题目描述

给出两个序列 pushed 和 poped 两个序列,其取值从 1 到 n(n\le100000)。已知入栈序列是 pushed,如果出栈序列有可能是 poped,则输出 Yes,否则输出 No。为了防止骗分,每个测试点有多组数据。

输入格式

第一行一个整数 q,询问次数。

接下来 q 个询问,对于每个询问:

第一行一个整数 n 表示序列长度;

第二行 n 个整数表示入栈序列;

第三行 n 个整数表示出栈序列;

输出格式

对于每个询问输出答案。

样例 #1

样例输入 #1

 2
 5
 1 2 3 4 5
 5 4 3 2 1
 4
 1 2 3 4
 2 4 1 3

样例输出 #1

 Yes
 No
 #include <iostream>   
 #include <algorithm>
 #include <vector>
 #include <string>
 #include <queue>
 #include <stack>
 #include <map>
 #include <set>
 #include <cstring>
 #include <cstdio>
 ​
 #define LL long long
 using namespace std;
 ​
 int q;
 int a[100005],b[100005];
 int n;
 stack<int> s;
 ​
 int main()
 {
     cin >>q;
     while (q--) {
         while (!s.empty())
         {
             s.pop();
         }
         memset(a,0,sizeof(a));
         memset(b,0,sizeof(b));
         cin >> n;
         for (int i = 1; i <= n; i++) {
             cin >> a[i];
         }
         for (int i = 1; i <= n; i++) {
             cin >> b[i];
         }
         int j = 1;//记录当前出栈的元素b[j]
         for (auto i = 1; i <= n ; i++)
         {
             s.push(a[i]);
             while ((s.top() == b[j]))//栈顶元素等于b[j],出栈
             {
                 s.pop();
                 j++;
                 if (s.empty()==1)//栈空了,跳出循环
                 {
                     break;
                 }
             }
         }
         if (s.empty() == 1)
         {
             cout << "Yes" << endl;
         }
         else
         {
             cout << "No" << endl;
         }
     }
     return 0;
 }

小行星碰撞 leetcode735

给定一个整数数组 asteroids,表示在同一行的小行星。

对于数组中的每一个元素,其绝对值表示小行星的大小,正负表示小行星的移动方向(正表示向右移动,负表示向左移动)。每一颗小行星以相同的速度移动。

找出碰撞后剩下的所有小行星。碰撞规则:两个小行星相互碰撞,较小的小行星会爆炸。如果两颗小行星大小相同,则两颗小行星都会爆炸。两颗移动方向相同的小行星,永远不会发生碰撞。

示例 1:

 输入:asteroids = [5,10,-5]
 输出:[5,10]
 解释:10 和 -5 碰撞后只剩下 10 。 5 和 10 永远不会发生碰撞。

示例 2:

 输入:asteroids = [8,-8]
 输出:[]
 解释:8 和 -8 碰撞后,两者都发生爆炸。

示例 3:

 输入:asteroids = [10,2,-5]
 输出:[10]
 解释:2 和 -5 发生碰撞后剩下 -5 。10 和 -5 发生碰撞后剩下 10 。

提示:

  • 2 <= asteroids.length <= 10^{4}

  • -1000 <= asteroids[i] <= 1000

  • asteroids[i] != 0

 class Solution {
 public:
     vector<int> asteroidCollision(vector<int>& asteroids) {
         vector<int> st;
         for (auto aster : asteroids) {
             bool alive = true;
             while (alive && aster < 0 && !st.empty() && st.back() > 0) {
                 alive = st.back() < -aster; // aster 是否存在
                 if (st.back() <= -aster) {  // 栈顶行星爆炸
                     st.pop_back();
                 }
             }
             if (alive) {
                 st.push_back(aster);
             }
         }
         return st;
     }
 };

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值