1009 FatMouse’ Trade 简单贪心算法

FatMouse' Trade

                                              Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)



Problem Description FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 
Input The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
 
Output For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 
Sample Input

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

 
Sample Output

13.333
31.500

 
Author CHEN, Yue  
Source ZJCPC2004  
Recommend JGShining

#include <stdio.h>
#include "stdlib.h"

/*
 
 老鼠用M猫粮换仓库里的鼠粮,仓库有n个房间,每个房间有num[i].javabean鼠粮,需要num[i].food猫粮换,
 可以换部分猫粮
 思路:简单的贪心问题,先算出性价比num[i].cost=(num[i].food*1.0)/num[i].javabean;
 然后从大到小排序,先从性价比高的开始换
 等到鼠粮或猫粮没有时结束(注意这是两种情况)
 */





typedef struct{//利用结构体
    int food,javabean;
    double cost;
}NUM;

int main()
{

  
    freopen("/Users/qigelaodadehongxiaodi/Desktop/data1.txt", "r", stdin);
    //这个不理,是用来方便输入输出的东西,利用文本输入流来读取数据
    //提交代码的时候记得注销这条语句
 
    
    int m,n;
    NUM num[1010];
    while(scanf("%d %d",&m,&n)!=EOF&&m!=-1&&n!=-1){

        for(int i=0;i<n;i++){
            scanf("%d %d",&num[i].javabean,&num[i].food);
            num[i].cost=(num[i].food*1.0)/num[i].javabean;
        }//读取数据
        
        
        for(int i=0;i<n;i++)
            for(int j=i;j<n;j++){
                if(num[i].cost>num[j].cost){
                    int temp=num[j].food;
                    num[j].food=num[i].food;
                    num[i].food=temp;
                    temp=num[j].javabean;
                    num[j].javabean=num[i].javabean;
                    num[i].javabean=temp;
                    
                    double temp1=num[j].cost;
                    num[j].cost=num[i].cost;
                    num[i].cost=temp1;
                }
            }//按照性价比从大到小排序
    
        int cnt=0;//记录是否把所有房间遍历
        double total=0.0;
        
        
        /*
        注意:此题有几个比较坑的数据
        
        0 1
        1 0
        1.000//虽然你没钱,但是免费的
        
        1 0
        0.000//虽然有钱,但是没房间,你要设置退出机制
        
        5 4
        10000 5
        2000 2
        100 0
        300 0
        10400.000
        */
        
        if(n!=0)//没房间时候退出机制
        while(m>=0){
            if(m>=num[cnt].food){  //加上等于,则有免费时候回继续提取
                
                total+=num[cnt].javabean;
                m=m-num[cnt].food;
            }else{
                
                total+=1.0*m/num[cnt].cost;
                m=0;
            }
            cnt++;
            if(cnt==n)break;//直到所有房间遍历完毕
            
        }
        printf("%.3lf\n",total);
    }
    
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

竖子敢尔

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值