1052 Tian Ji -- The Horse Racing 田忌赛马 贪心算法

Tian Ji -- The Horse Racing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 18155    Accepted Submission(s): 5281


 

Problem Description Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"



Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.
 
Input The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.
 
Output For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.
 
Sample Input

3
92 83 71
95 87 74
2
20 20
20 20
2
20 19
22 18
0

 
Sample Output

200
0
0

 
Source 2004 Asia Regional Shanghai
 

#include <stdio.h>
#include "stdlib.h"

/*
 解题报告:
 关键在于田忌最慢的马,能先赢就先赢,不能赢就去消耗齐王最快的马,
 然后再来考虑最快的马,能先赢就先赢,不能赢说明现在田忌和齐王最快的
 马和最慢的马都相等,再来考虑把田忌最慢的马和齐王最快的马比较。
 可能更小,但也可能相等。(要按顺序噢!)
 1.当田忌最慢的马比齐王最慢的马快,赢一场先
 2.当田忌最慢的马比齐王最慢的马慢,和齐王最快的马比,输一场
 3.当田忌最快的马比齐王最快的马快时,赢一场先。
 4.当田忌最快的马比齐王最快的马慢时,拿最慢的马和齐王最快的马比,输一场。
 5.当田忌最快的马和齐王最快的马相等时,拿最慢的马来和齐王最快的马比.

*/





void sort(int ma[],int n){
    for(int i=0;i<n;i++)
        for(int j=i;j<n;j++){
            
            if(ma[i]<ma[j]){
                int temp=ma[i];
                ma[i]=ma[j];
                ma[j]=temp;
            }
        }
}

int main()
{
    
    freopen("/Users/qigelaodadehongxiaodi/Desktop/data1.txt", "r", stdin);
    //这个不理,是用来方便输入输出的东西,利用文本输入流来读取数据
    //提交代码的时候记得注销这条语句
    
    int n;
    int tianji[1020],king[1020];
    
    while(scanf("%d",&n)){
        if(n==0)return 0;
        
        for(int i=0;i<n;i++){
            scanf("%d ",&tianji[i]);
 
        }
        for(int i=0;i<n;i++){
            scanf("%d ",&king[i]);

        }
        
        sort(tianji,n);
        sort(king,n);
        
        
        //从快到慢排完序,下面的tianjisS表示第一个下标,tianjiE表示末尾的下标
        int tianjiS=0,tianjiE=n-1;
        int kingS=0,kingE=n-1;
        int cnt=0;
        int total=0;
        while(cnt<n){
            
            if(tianji[tianjiE]>king[kingE]){//比较两边最慢的马,
                tianjiE--;//如果我方慢的大,直接吃了对方,比完后田忌最慢的马被消耗了
                kingE--;//比完之后,国王最慢的消耗了,则往前走一个位置
                cnt++;
                total+=200;
            }else
                if(tianji[tianjiE]==king[kingE]){
                    //假如相等,则田忌不知道拿最慢的马去和国王最慢的马比,
                    //或者拿去输给国王最快的马当炮灰
                    //则比较两边最快的马
                  
                    if(tianji[tianjiS]<=king[kingS]){//比较两边最快的马
                        
                        
                        if(tianji[tianjiE]<king[kingS])
                            total-=200;//输了一场
                        else total+=0;// 平局
                        
                        
                        kingS++;
                        tianjiE--;
                        cnt++;
                        //  total-=200;//输了一场
                        
                    }else{//表示田忌最快的马更快,则直接赢过往最快的马
                        kingS++;
                        tianjiS++;
                        cnt++;//表示比较了一组
                        total+=200;//赢了一场
                    }
 
                }else{//假如田忌最慢的马全宇宙最慢,则只能拿去当炮灰,消耗国王最快的马
                    total-=200;
                    tianjiE--;
                    kingS++;
                    cnt++;
                }
            
            
        }

        printf("%d\n",total);
  
        
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

m0_72431373

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值