L.循环练习(求两个数的最大公约数和最小公倍数)

Description
n(n<100)组测试数据。每组测试数据输入两个正整数a和b,输出这两个数的最大公约数和最小公倍数。

Input
第一行输入整数n,表示n组测试数据。
以下每行输入两个正整数a和b,数据之间空格分隔。

Output
按格式输出这两个数的最大公约数和最小公倍数。
每组输出数据占两行。
Sample Input
1
45 36
Sample Output
Greatest common divisor is 9
Lease common multiple is 180
#include<iostream>
#include<iomanip>
using namespace std;
int gongyueshu(int m, int n) {
	int temp = n;
	while (m % n != 0) {
		temp = m % n;
		m = n;
		n = temp;
	}
	return temp;
}
int main() {
	int n;
	cin >> n;
	while (n--) {
			int a, b;
			cin >> a >> b;
			int c = gongyueshu(a, b);
			int d = a * b / c;
			cout <<"Greatest common divisor is " << c <<endl<<"Lease common multiple is " << d <<endl;
	}
}

 反思;使用方法:辗转相除法

最小公倍数=双数之积除以最大公约数;

另一种循环的方法,更易理解:

#include<bits/stdc++.h>
using namespace std;
int gcd(int a, int b) {
	int t = max(a, b);
	for(int i=t;i>=2;i--){
		if (a % i == 0 && b % i == 0) return i;
	}
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ou_fan

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值