E.互质数(水题)

Description
给定两个正整数a、b,判断两个数是否为互质数(除1外,两个数没有相同的因子)。根据Hint中给出的主函数定义函数并给出实现。
Input
本题有多组测试数据。
第一行只有一个正整数n,代表更有n组测试数据。
之后为n行,每行对应一组测试数据,包含两个正整数a、b。
Output
针对每组测试数据输出一行,如果a、b为互质数,输出格式为:
a and b are coprime numbers.
如果a、b不是互质数,输出格式为:
a and b are not coprime numbers.
其中a、b为测试数据。
Sample Input
5
3 5
5 10
7 9
9 12
11 13
Sample Output
3 and 5 are coprime numbers.
5 and 10 are not coprime numbers.
7 and 9 are coprime numbers.
9 and 12 are not coprime numbers.
11 and 13 are coprime numbers.
Hint
int main(){
    int n,a,b;
    cin>>n;
    while(n--){
        cin>>a>>b;
        coprime(a,b);
    }
}

#include<bits/stdc++.h>
using namespace std;
const int N = 1000010;
void coprime(int a,int b) {
    int MIN = min(a, b);
    bool vis = true;
    for (int i = 2;i <= MIN;i++) {
        if (a % i == 0&&b%i==0) {
            vis = false;
            break;
        }
    }
    if (vis)cout << a << " and " << b << " are coprime numbers." << endl;
    else cout << a << " and " << b << " are not coprime numbers." << endl;
}
int main() {
    int n, a, b;
    cin >> n;
    while (n--) {
        cin >> a >> b;
        coprime(a, b);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ou_fan

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值