序列的第k个数—快速幂

 

输入样例:

2
1 2 3 5
1 2 4 5

输出样例:

5
16

 

#include <bits/stdc++.h>
#define endl '\n'
#define int long long
using namespace std;
constexpr int N = 1e5;
const int mod = 200907;		
int a, b, c, k;
int qmi(int x, int n) {
	int res = 1;
	while (n) {//对指数进行操作
		if (n & 1) res = res * x % mod;
		x = x * x % mod;
		n >>= 1;
	}
	return res;
}
void solve1() {
	int d = b - a;
	int ans = a + (k - 1) * d;
	cout << ans % mod << endl;
}
void solve2() {
	int q = b / a;
	int ans = a * qmi(q, k - 1);
	cout << ans%mod << endl;
}
signed main() {
	ios_base::sync_with_stdio(0);
	cin.tie(0); cout.tie(0);
	int T;
	cin >> T;
	while (T--) {
		cin >> a >> b >> c>>k;
		bool flag=false;
		if (a + c == b + b) {
			flag = true;
		}//是等差
		if (flag) {
			solve1();
		}
		else {
			solve2();
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ou_fan

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值