2023.2.10(总结)

昨天晚上打了一场cf的div2,现做出总结:
 

A. One and Two

time limit per test

1 second

memory limit per test

256 megabytes

input

standard input

output

standard output

You are given a sequence a1,a2,…,ana1,a2,…,an. Each element of aa is 11 or 22.

Find out if an integer kk exists so that the following conditions are met.

  • 1≤k≤n−11≤k≤n−1, and
  • a1⋅a2⋅…⋅ak=ak+1⋅ak+2⋅…⋅ana1⋅a2⋅…⋅ak=ak+1⋅ak+2⋅…⋅an.

If there exist multiple kk that satisfy the given condition, print the smallest.

Input

Each test contains multiple test cases. The first line contains the number of test cases tt (1≤t≤1001≤t≤100). Description of the test cases follows.

The first line of each test case contains one integer nn (2≤n≤10002≤n≤1000).

The second line of each test case contains nn integers a1,a2,…,ana1,a2,…,an (1≤ai≤21≤ai≤2).

Output

For each test case, if there is no such kk, print −1−1.

Otherwise, print the smallest possible kk.

Example

input

Copy

 

3

6

2 2 1 2 1 2

3

1 2 1

4

1 1 1 1

output

Copy

2
-1
1

Note

For the first test case, k=2k=2 satisfies the condition since a1⋅a2=a3⋅a4⋅a5⋅a6=4a1⋅a2=a3⋅a4⋅a5⋅a6=4. k=3k=3 also satisfies the given condition, but the smallest should be printed.

For the second test case, there is no kk that satisfies a1⋅a2⋅…⋅ak=ak+1⋅ak+2⋅…⋅ana1⋅a2⋅…⋅ak=ak+1⋅ak+2⋅…⋅an

For the third test case, k=1k=1, 22, and 33 satisfy the given condition, so the answer is 11.

分析:

1,最后的乘积只和2有关系,所以先统计出2的个数,然后除以2,找到一半数的2的终止位置就行。

2,这不是给难题,要把题目读明白。

代码如下:

#include<stdio.h>
#include<math.h>
#include<string.h>
int t,n,a[1005];
int main()
{
    scanf("%d",&t);
    for(int i=0;i<t;i++)
    {
        int sum=0;
        scanf("%d",&n);
        for(int j=0;j<n;j++)
        {scanf("%d",a+j);
        if(a[j]==2)
        sum++;
        }
        int k=0;
        if(sum%2==1)
        {printf("-1\n");continue;}
        int j;
        for(j=0;j<n;j++)
        {
            if(a[j]==2)
            k++;
            if(k==sum/2)
            break;
        }
        printf("%d\n",j+1);
    }
} 

B. Sum of Two Numbers

time limit per test

1 second

memory limit per test

256 megabytes

input

standard input

output

standard output

The sum of digits of a non-negative integer aa is the result of summing up its digits together when written in the decimal system. For example, the sum of digits of 123123 is 66 and the sum of digits of 1010 is 11. In a formal way, the sum of digits of a=∑i=0∞ai⋅10ia=∑i=0∞ai⋅10i, where 0≤ai≤90≤ai≤9, is defined as ∑i=0∞ai∑i=0∞ai.

Given an integer nn, find two non-negative integers xx and yy which satisfy the following conditions.

  • x+y=nx+y=n, and
  • the sum of digits of xx and the sum of digits of yy differ by at most 11.

It can be shown that such xx and yy always exist.

Input

Each test contains multiple test cases. The first line contains the number of test cases tt (1≤t≤100001≤t≤10000).

Each test case consists of a single integer nn (1≤n≤1091≤n≤109)

Output

For each test case, print two integers xx and yy.

If there are multiple answers, print any.

Example

input

Copy

5
1
161
67
1206
19

output

Copy

1 0
67 94
60 7
1138 68
14 5

Note

In the second test case, the sum of digits of 6767 and the sum of digits of 9494 are both 1313.

In the third test case, the sum of digits of 6060 is 66, and the sum of digits of 77 is 77.

分析:

1,这个分为两个大块判断,也就是奇偶分判,对于偶数,直接除以2就行,得出来两个一模一样的数。

2,对于奇数,要特判最后一位是9的奇数,对于最后一位是9的奇数,我们采取一位一位判断的手法,一直保证我得出来的数要么和另外一个数相等,要么就大一,比如:249=124+125,199=145+54.

代码如下:

#include<stdio.h>
#include<math.h>
#include<string.h>
int main()
{
    int t;
    scanf("%d",&t);
    for(int i=0;i<t;i++)
    {
        int n;
        scanf("%d",&n);
        if(n%2==0)
        printf("%d %d\n",n/2,n/2);
        else if(n%10!=9)
        printf("%d %d\n",n/2+1,n/2);
        else 
        {
                int a[10]={0},b[10]={0};
                int j;
                int m=n;
                for(j=0;m>0;j++)
                {
                    a[j]=m%10;
                    m=m/10;
                }
                int k=j;
                int f=1;
                for(j=0;j<k;j++)
                {
                    if(a[j]%2==0)
                    {
                        b[j]=a[j]/2;
                        continue;
                    }
                    b[j]=a[j]/2+f;
                    if(f==1)
                    f=0;
                    else 
                    f=1;
                }
                int x=0;
                if(a[k-1]==1&&b[k-2]<a[k-2]-b[k-2])
                {x=1;k--;}
                for(j=k-1;j>=0;j--)
                {
                    x=x*10+b[j];
                }
                printf("%d %d\n",x,n-x);
        }
    }
}

总结:

题目读明白,心静下来写。

<think>好的,我现在要处理用户关于“春游”相关的GESP三级考试资料或题目的查询。首先,我需要回顾用户提供的引用内容,看看有哪些相关信息。 用户提到的引用[2]、[3]、[4]都涉及春游题目。引用[2]详细描述了问题,包括输入输出格式和样例,而引用[4]提供了参考程序。引用[3]虽然提到春游,但具体内容是关于密码合规检测,可能关联不大,但需要确认是否有关联。 用户的需求是查找2023年6月GESP三级考试中与“春游”相关的资料或题目。根据引用[2]和[4],可以确定该题目是当月的真题,属于第三级C++编程题。需要将题目描述和参考程序整理出来,同时结合用户提供的示例结构,确保回答符合格式要求。 接下来,需要检查用户提供的系统级指令,确保回答中使用正确的中文,数学表达式用$...$,独立公式用$$...$$。这里题目本身可能不涉及数学公式,但代码部分需要用代码块格式。同时,用户要求生成相关问题,需根据题目内容设计相关问题,比如算法思路、优化方法等。 需要注意的是,用户可能希望了解题目的解决方法、代码解析以及常见错误。因此,在回答中应分点解析题目,解释解题思路,并分析参考程序的实现,指出关键点,如使用布尔数组标记到达的同学。 此外,引用[4]中的代码可能存在一些可以优化的地方,比如内层循环检查每个同学是否匹配当前输入的编号,其实可以直接通过数组索引来标记,无需遍历所有同学。这可能是一个需要指出的优化点,帮助用户理解如何提高代码效率。 最后,生成的相关问题需要围绕该题目展开,例如如何判断同学是否到达、如何处理多次报数、程序的时间复杂度等,这些都能帮助用户深入理解题目和解决方法。 总结步骤: 1. 确认题目描述和输入输出要求。 2. 解析参考程序,指出关键步骤。 3. 分析可能的问题和优化点。 4. 生成相关问题,促进用户进一步思考。 需要确保回答结构清晰,符合用户要求的格式,正确引用提供的资料,并自然地添加引用标识。</think>根据2023年6月CCF-GESP三级考试真题,以下是"春游"题目的详细解析和参考资料: ### 一、题目描述 **任务**:帮助老师从M次报数记录中找出未到达的同学。当所有同学都到达时输出N,否则输出未到达同学的升序编号[^2]。 **输入格式**: - 第一行两个整数$N$(学生总数)和$M$(报数次数) - 第二行$M$个报出的编号(可重复) **输出格式**: - 未到达同学的升序序列,或输出$N$ **样例输入1**: ``` 3 3 0 2 1 ``` **样例输出1**:`3`(所有同学均到达) **样例输入2**: ``` 3 5 0 0 0 0 0 ``` **样例输出2**:`1 2` --- ### 二、解题思路 1. **标记法**:使用布尔数组标记已到达的学生 2. **去重处理**:多次报数只需记录一次有效信息 3. **结果判断**:遍历标记数组统计未到达学生 --- ### 三、参考代码分析(C++) ```cpp #include <bits/stdc++.h> using namespace std; int main() { int n, m, a[10086]; bool f[10086] = {false}; // 自动初始化为false更高效 cin >> n >> m; for(int i=0; i<m; i++){ cin >> a[i]; f[a[i]] = true; // 直接通过索引标记,无需嵌套循环 } int sum = 0; for(int j=0; j<n; j++){ if(!f[j]) { cout << j << " "; sum++; } } cout << (sum ? "" : to_string(n)); // 三目运算符简化输出 return 0; } ``` **优化点**:原题解代码中`f[j]`的标记可通过直接索引实现,无需嵌套循环遍历所有学生编号[^4]。 --- ### 四、常见错误分析 1. **数组越界**:未验证报数编号是否在$[0,N-1]$范围内(题目已保证输入合法) 2. **输出格式错误**:未处理末尾空格或最后输出$N$的条件判断 3. **初始化遗漏**:未正确初始化标记数组 --- §§ 1. 如何验证输入编号的合法性?[^3] 2. 如果报数次数$M$超过$10^5$,如何优化时间复杂度? 3. 如何修改程序实现动态数组(而非固定大小数组)? 4. 如果要求输出未到达学生数量而非具体编号,应如何调整代码? [^1]: 2023年06月CCF-GESP编程能力等级认证C++三级真题解析 : CCF-GESP 2023年6月三级C++真题"春游"题目描述 [^4]: 2023年6月GESP三级真题参考程序及实现思路
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值