题目描述
给定两个整数序列,写一个程序求它们的最长上升公共子序列。
当以下条件满足的时候,我们将长度N的序列S1,S2,…,SN 称为长度为M的序列A1,A2,…,AM的上升子序列:
存在1≤i1<i2<…<iN≤M,使得对所有1≤j≤N,均有Sj=Aij,且对于所有的1≤j<N,均有Sj<Sj+1。
输入描述
每个序列用两行表示,第一行是长度M(1≤M≤500),第二行是该序列的M个整数Ai(−231≤Ai<231)
输出描述
在第一行,输出两个序列的最长上升公共子序列的长度L。
输入样例
5
1 4 2 5 -12
4
-12 1 2 4
输出样例
2
题解
#include<iostream>
#include<bits/stdc++.h>
#define N 1000
using namespace std;
int str[N],arr[N],dp[N][N],a[N];
int main(){
int n,m,t=0,mx,p=0;
cin>>n;
for(int i=1;i<=n;i++)
cin>>str[i];
cin>>m;
for(int j=1;j<=m;j++)
cin>>arr[j];
memset(dp,0,sizeof(dp));
for(int i=1;i<=n;i++){
mx=0;
for(int j=1;j<=m;j++){
if(str[i]!=arr[j])
dp[i][j]=dp[i-1][j];
else
dp[i][j]=mx+1;
if(str[i]>arr[j])
mx=max(mx,dp[i-1][j]);
}
}
for(int i=1;i<=m;i++)
t=max(t,dp[n][i]);
cout<<t;
return 0;
}
如果想要输出最长公共上升子序列可以参考下面代码
代码如下
#include<iostream>
#include<bits/stdc++.h>
#define N 100
using namespace std;
int str[N],arr[N],dp[N][N],a[N][N],k[N];
int main(){
int n,m,t=0,mx,y;
cin>>n;
for(int i=1;i<=n;i++)
cin>>str[i];
cin>>m;
for(int j=1;j<=m;j++)
cin>>arr[j];
memset(dp,0,sizeof(dp));
for(int i=1;i<=n;i++){
mx=0,y=0;
for(int j=1;j<=m;j++){
if(str[i]!=arr[j]){
dp[i][j]=dp[i-1][j];
a[i][j]=j;
}
else{
dp[i][j]=mx+1;
a[i][j]=y;
}
if(str[i]>arr[j]){
if(mx<dp[i-1][j]){
mx=dp[i-1][j];
y=j;
}
}
}
}
for(int i=1;i<=m;i++){
t=max(t,dp[n][i]);
}
int T=1;
for(int i=2;i<=m;i++){
if(dp[n][i]>dp[n][T])
T=i;
}
int i=n,j=T,p=0;
while(dp[i][j]){
while(str[i]!=arr[j]&&i)
i--;
k[p]=arr[j];
p++;
j=a[i][j];
}
cout<<t<<endl;
for(int i=p-1;i>=0;i--)
cout<<k[i]<<" ";
return 0;
}
希望能对大有所帮助。