【无标题】乘坐电梯(lift)--包河区T3

题目描述

n 个人从一楼乘电梯回家,给出他们想要到达的楼层,请计算所 有人乘梯所用时间之和。时间的计算方法:在一楼进电梯,第 1 个人 用时 1 秒,第 2 个人用时 2 秒,……,第 i 个人用时 i 秒;电梯每上升一层,用时 1 秒;出电梯时,在同一楼层,第 1 个人用时 1 秒,第 2 个人用时 2 秒,……,第 i 个人用时 i 秒。

输入格式

两行。第一行一个正整数 n,表示乘梯人数;第二行 n 正整数,表示 每个人要到达的楼层。

输出格式

一行。一个整数,表示整个用时,单位是秒。

输入样例:   

3

13 18 13                         

输出样例:

27

代码:

#include<iostream>
#include<cmath>
#include<cstdio>
using namespace std;
int cnt[10000],ans;
int main(){
    int n,maxn=0;
    cin>>n;
    for(int i=1;i<=n;i++){
        int x;
        cin>>x;
        cnt[x]++;
        maxn=max(maxn,x);
    }
    ans+=(1+n)*n/2;
    for(int i=2;i<=maxn;i++){
        ans++;
        if(cnt[i]!=0){
            ans+=(1+cnt[i])*cnt[i]/2;
        }
    }
    cout<<ans;
    return 0;
}

加油哦!!!

特别的电梯问题通常是指在编程中对于电梯调度算法的一个具体案例或练习。这类问题可能会涉及到如何设计电梯控制逻辑,使其能够高效地响应楼层间的呼叫请求,并优化电梯的运行效率和乘客的等待时间。 对于题目中的"2022庐阳区小学-T4"电梯代码,这是一个假设的场景,实际上并没有公开的代码可以参考。但一般而言,解决这类问题的思路可能包括: 1. 定义电梯的状态,例如当前楼层、目标楼层、电梯运行方向等。 2. 接收楼层间的呼叫请求,并将其加入到一个请求队列中。 3. 实现调度算法来决定电梯的运行逻辑,比如响应请求的顺序,以及电梯的移动方向。 4. 确保电梯在运行过程中的安全性和效率,例如避免频繁的启动和停止。 这里提供一个非常简化的电梯调度逻辑伪代码示例: ```python class Elevator: def __init__(self): self.current_floor = 0 self.target_floors = [] self.direction = 'up' # 可能的值为'up'或'down' def call_elevator(self, floor): self.target_floors.append(floor) self.target_floors = sorted(set(self.target_floors)) def move(self): if self.target_floors: next_floor = self.target_floors[0] if (self.direction == 'up' and self.current_floor < next_floor) or \ (self.direction == 'down' and self.current_floor > next_floor): self.current_floor += 1 if self.direction == 'up' else -1 else: self.direction = 'down' if self.direction == 'up' else 'up' self.current_floor += 1 if self.direction == 'up' else -1 if self.current_floor == next_floor: self.target_floors.pop(0) self.direction = 'up' if self.target_floors else 'down' ``` 请注意,这只是一个非常基础的示例,实际的电梯调度系统会更加复杂,需要考虑更多的情况和优化。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值