1002 A+B for Polynomials(c语言实现)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1​ aN1​​ N2​ aN2​​ ... NK​ aNK​​

where K is the number of nonzero terms in the polynomial, Ni​ and aNi​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NK​<⋯<N2​<N1​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

 思路:

  1. 该题主要是要找存储多项式的指数和系数的容器
  2. 一种容器是定义一个一维数组,多项式的指数作为数组下标,其指数对应的系数为数组下标对应的元素
  3. 另一种容器是定义一个结构(struct),里面包含exponent以及coefficient,以链表的形式将多项式串联起来
  4. 本方法采用的是一维数组的方式
  5. python实现(python实现
#include <stdio.h>
int main(void){
    //定义一个1001大小的数组,数组的index作为exponent,数组index对应的元素作为coefficient
    double a[1001] = {0};
    int n;//接收数据K
    int count = 0;//记录数组非0项的个数,即多项式的个数
    scanf("%d", &n);
    int i, ex;
	double coe;
    for(i = 0; i < n; i++){
        scanf("%d %lf", &ex, &coe);
        a[ex] += coe;
    }
    scanf("%d", &n);
    for(i = 0; i < n; i++){
        scanf("%d %lf", &ex, &coe);
        a[ex] += coe;
    }
    for(i = 0; i <= 1000; i++){
        if(a[i]!=0){
            count++;
        }
    }
    printf("%d", count);
    if(count > 0){
        for(i = 1000; i >= 0; i--){
            if(a[i] != 0){
                printf(" %d %.1lf", i, a[i]);
            }
        }
    }
    
    
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值