贪心算法-钱币支付


//待支付钱币total,钱币种树n,每种钱币不限张数
//使用最少的钱币张数去支付
//样例输入:
//58 4
//样例输出
//7
#include<iostream>
#include<algorithm>
using namespace std;
int total, n, ans;
int a[100];
bool cmp(int a, int b)
{
    return a > b;
}
int main()
{
    cin >> total >> n;
    for (int i = 0; i < n; i++)
        cin >> a[i];
    sort(a, a + n,cmp);
    for (int i = 0; i < n; i++)
    {
        /*while (a[i] <= total)
        {
            total -= a[i];
            ans++;
        }*/
        if (a[i] <= total)  //优化
        {
            int num = total / a[i];
            ans += num;
            total -= a[i] * num;
        }
    }
    cout << ans;
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

另一个人。

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值