L2-006 树的遍历

给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。

代码长度限制 16 KB   时间限制 400 ms   内存限制 64 MB

输入格式:

输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

输出样例:

4 1 6 3 5 7 2

分析:根据树结构的特点进行递归处理,每次将得到的数据进行排序。

#include <bits/stdc++.h>
using namespace std;
vector<int> in,post;
map<int,int> mp;
void pre(int root,int l,int r,int index)
{
    if(l>r) return ;
    int i=l;
    while(i<r&&in[i]!=post[root]) i++;
    mp[index]=post[root];
//root-1得到只有左子树和右子树的后序遍历,r-i是后序遍历中右子树的数量;
//root-1-(r-i)得到左子树最后的元素下标
    pre(root-1-(r-i),l,i-1,2*index+1);
    pre(root-1,i+1,r,2*index+2);
    
}
int main()
{
    int n;
    cin>>n;
    in.resize(n);
    post.resize(n);
    for(int i=0;i<n;i++) cin>>post[i];
    for(int i=0;i<n;i++) cin>>in[i];
    pre(n-1,0,n-1,0);
    auto it=mp.begin();
    cout<<it->second;
    while(++it!=mp.end()) cout<<" "<<it->second;

    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值