L2-006 树的遍历(25 分)

给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

输出样例:

4 1 6 3 5 7 2

 根据二叉树的后序中序恢复一棵二叉树,然后层次遍历恢复的二叉树。

#include<bits/stdc++.h>
using namespace std;
//思路:递归求解 分两个部分 恢复二叉树restree和利用队列层次遍历函数leveltra
vector<int> posord;
vector<int> midord;
//定义一个二叉树结构体
typedef struct btnode{
    int Data;
    struct btnode *Left,*Right;
}BTnode,*BTree;
//restree函数三个参数分别是后序遍历中的根节点,中序遍历的起点,中序遍历的终点
BTree restree(int root,int begin,int end){
    if(begin>end) return NULL;//叶子节点无子树
    int rnt;
    for(rnt=begin;rnt<end;rnt++)//在中序里找到根节点的位置
    {
        if(midord[rnt]==posord[root])
            break;
    }
    BTree Bt=BTree(malloc(sizeof(struct btnode)));
    Bt->Data=posord[root];
    Bt->Left=restree(root-1-(end-rnt),begin,rnt-1);
    Bt->Right=restree(root-1,rnt+1,end);
    return Bt;
}
void leveltra(BTree bt){
    queue<BTree> que;
    int flag=1;
    BTree temp = NULL;
    que.push(bt);
    while(!que.empty()){
        temp = que.front();
        if(flag)
        {
            cout<<temp->Data; 
            flag=0;
        }
        else
            cout<<" "<<temp->Data;
        que.pop();
        if(temp->Left)
             que.push(temp->Left);
         if(temp->Right)
             que.push(temp->Right);
    }
}
int main(){
    int n;
    cin>>n;
    int m;
    for(int i=0;i<n;i++)
    {
        cin>>m;
        posord.push_back(m);
    }
    for(int i=0;i<n;i++)
    {
        cin>>m;
        midord.push_back(m);
    }
    leveltra(restree(n-1,0,n-1));
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

飞飞鱼_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值