AcWing 802. 区间和(C++)(离散化)(差分)

目录

1.题目描述

2.AC


1.题目描述

假定有一个无限长的数轴,数轴上每个坐标上的数都是 00。

现在,我们首先进行 nn 次操作,每次操作将某一位置 xx 上的数加 cc。

接下来,进行 mm 次询问,每个询问包含两个整数 ll 和 rr,你需要求出在区间 [l,r][l,r] 之间的所有数的和。

输入格式

第一行包含两个整数 nn 和 mm。

接下来 nn 行,每行包含两个整数 xx 和 cc。

再接下来 mm 行,每行包含两个整数 ll 和 rr。

输出格式

共 mm 行,每行输出一个询问中所求的区间内数字和。

数据范围

−109≤x≤109−109≤x≤109,
1≤n,m≤1051≤n,m≤105,
−109≤l≤r≤109−109≤l≤r≤109,
−10000≤c≤10000

输入样例:

3 3
1 2
3 6
7 5
1 3
4 6
7 8

输出样例:

8
0
5

2.AC

#include <iostream> 
#include <cstdio>
#include <vector>
#include <algorithm>
using namespace std;
typedef pair<int, int> PII;
const int N = 3e5 + 10;
int n, m;
int a[N], s[N];
vector<int> alls;
vector<PII> add, query;
int find (int x) {
	int l = 0, r = alls.size()-1;
	while (l < r) {
		int mid = l + r >> 1;
		if (x>alls[mid]) l = mid + 1;
		else r = mid;
	}
	return r+1;
}
int main () {
	scanf("%d%d", &n, &m);
	for (int i = 0; i < n; i++) {
		int x, c;
		scanf("%d%d", &x, &c);
		add.push_back({x, c});
		alls.push_back(x);
	}
	for (int i = 0; i < m; i++) {
		int l, r;
		scanf("%d%d", &l, &r);
		query.push_back({l, r});
		alls.push_back(l);
		alls.push_back(r);
	}
	//去重 
	sort(alls.begin(), alls.end());
	alls.erase(unique(alls.begin(), alls.end()), alls.end());
	//处理插入 
	for (auto item : add) {
		int x = find(item.first);
		a[x] += item.second;
	}
	//预处理前缀和 
	for (int i = 1; i <= alls.size(); i++) s[i] = s[i-1] + a[i];
	//处理询问 
	for (auto item : query) {
		int l = find(item.first);
		int r = find(item.second);
		printf("%d\n", s[r] - s[l-1]);
	}
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值